Any idea what may be causing distorted fonts in Discord?

Example here:

I'm using the PTB beta version installed from deb but prior to that I tried using the standard release also from deb and got the same font issue and tried using the Snap but that also had troubles. So I'm putting it out there to see if anyone has any ideas.

Since I am using the Bionic Beta I'm pretty sure that's related but I'm not sure how. Is Discord a QT application (cannot find this information any where) if so would installing something to tweak the preferred fonts be useful with a QT themer? On the other hand VLC is QT IIRC and it looks fine without any font issues, as does Vid Cutter.

Suggestions please!

OK, I gave the Snap another try and this time the application loaded for me. It looks perfect. I don't know what is causing the font distortions from the direct installed deb versions of both the standard deb and the ptb version.

(This is how it's supposed to look and this is the Snap version of the application, now working.)

That said when I was removing the Snap version previously the menu item which at that point did not load the application was left behind after the removal so I deleted it in the menu editor. Could someone please tell me if there is a way to re-install the menus or could a fellow Discord snap user provide the command to run and I'll recreate the item manually?

I don't know much about Snaps despite hearing about them off and on. I've generally stuck with PPAs and debs in the past.

Thanks again for any assistance!

EDIT: Okay, I followed one of my other snaps to this address and found what I needed minus the application icon:


Could someone please tell me for future reference where Snap keeps its icons for installed applications? I'm using one I downloaded off of Google for now, but since Snap is intended to be the way forward I'd appreciate a pointer to where to find the icons of Snap applications.

Thanks again.

Hi @bornagainpenguin,

follow this path: File System > snap > core > choose one of the numbered folders (there are 3) > usr > share > icons. :smiley:

I hope it helps. :smiley:

1 Like

Unfortunately based on the icons shown from those paths, all icons are for gvim. None of them are for Discord. Not sure how that works.

I guess once the beta is over I can try reinstalling from final and that will put the menu items where they belong when I do the snap install.

Unless maybe you can think of somewhere else where a snap might install menu icons?

Thanks for the reply.

I am not sure about Discord so I think it might be down to what theme you are using, have you checked Mate Tweak to see if all your desired settings are in place?, you can also try disabling compositing which may help?. :smiley: