Anyone have duel monitors working Properly in 16.04

Hi everyone
Over the last 6 months I have installed 16.04 on my main PC and 2 of my friends PCs. We all run duel monitors and all hardware is different but we are all having the same bug. Some programs, system windows and copy/paste files go to the secondary monitors even if the monitor is turned off. I have googled the issue for months now, modified settings in Compiz and Marco nothing I do has any effect on the problem at all. We are all running TVs in another room or across a large room so when this happens it really slows down workflow, especially when the TV is off and a file gets sent there. Is Ubuntu not able to properly handle a duel monitor/ triple monitor setups or is there something I am missing? Any help will be greatly appreciated by all three of us.
Thanks in advance.

Hi @freecat,

you need to tell us what GPU drivers (if any) you have installed and what GPU’s you have please!. :smiley:

Have you run any fixes in Welcome?, see the update guide and the first 3 pics!:

See also:

Thanks for the reply Wolfman
I have installed all updates listed in the software updater.
My graphics card is XFX GHOST R7800 series
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]
I am running the default driver from when I first installed 16.04
Software and updates does not show any drivers available for this card and I have not installed any fixes from the Welcome center.
This really seems like a windows manager issue more than a driver issue. 80% of the time something is sent to the wrong monitor it is system related like a copying a file to the desktop or the confirmation dialog for emptying the trash. I do not have the GPU info for my friends PCs right now but am more worried about getting my problems sorted ATM.

Try running “dpkg” per the update guide linked above (a network cable connection is required!). :smiley:

Hi Wolfman
I ran dpkg per the instructions in your link. It found a few pulseaudio and Google earth packages but that was it. The software updater shows everything is up to date as well. Any ideas on where to go from here.
thanks for all the help

hi @freecat,

I do have a question about how you installed, did you use a DVD or USB stick and did you follow the following advice?:

On my PC I did the install from a dvd created with imgburn in windows 7. I used the same ISO to create two more DVDs in linux that I used to do the install on my friends PCs that are having the same issue. I did use the slowest speed on each burn and verified the disk.

Hi @freecat,

I’m not really sure as I don’t do it, maybe look for something along the following lines which might give you a hint?:

Thanks for all the help Wolfman. I have come to the conclusion that the problem I am having is just a bug in Ubuntu. I tried installing several different versions on another PC with duel monitors and they did the same thing. Maybe in the future someone that has found a answer will come across this topic and post a fix.
Thanks again

Hi @freecat,

I have noticed that you have a Radeon GPU, did you check this link out (it’s in the graphics card installation guide link!):–Release-Notes.aspx

I haven’t got any experience of dual monitors, they are a bit of a mystery to me, so take this as wild speculation.

There sounds like two problems here: first the video driver not detecting the TV is off and as a consequence the virtual screen size is being overly large. Second, when the TV is on, the window manager is not following the mouse pointer correctly.

I’m sure you’ve found this link in your googling . Do none of the suggestions there and in the linked launchpad bug work?

How have you set up your dual monitors? Have you defined an xorg.conf or anything custom like that?




I have a triple monitor setup and mine works exactly the same. Just because the monitor is switched off will have no effect on the system thinking it is attached. You physically have to remove the cable to advise the system it is not there or tell the system you do not want to use it this time round and disable it in monitor settings or via the specific settings program you have installed with your graphics card. (mine is nvidia-settings)

I distro hop a lot and exactly the same thing happens in every version of linux I use. As for the application appearing on the wrong screen. Disconnect that screen or make it disabled and that problem goes away.

Not the solution you are after I am sure but it is what it is from my experience, unless someone with more technical knowledge, can tell you otherwise

Regards Zeb…

1 Like

When you say switched off, do you mean on standby? I’m just wondering if it is some problem with DPMS? I don’t think what you describe is desired behaviour, so I’d be tempted to raise a bug and pick the brains of some xorg person.

Going back to the OP, really what is being described is multi-seat. If the second monitor/tv is in a different room then using it to extend the workspace doesn’t make sense. You could try something like mutter, I’ve read that it somehow handles workspaces differently on different monitors, but I’ve got no experience of it.

If you use the second monitor/tv just to watch videos, then a workaround would be just to set it up so that it is always disabled. Then, setup a script which runs when you open your video player that enables the tv and positions the video player on that part of the workspace.

@Wolfman It does not look like any of those drivers will work with my card.
@veggrower Files and programs get sent to the second screen even when it is completely off. Even though the tv is in a different room the other installs I have done on test PCs and friends PCs have done the same thing local monitors and would like to get things working correctly. I have tested this on several distros over the last week and agree with ZebedeeBoss, this is a bug in Linux. I guess I will have to live with it for now or hook the TV up to my win 7 PC.
Thanks for the replys