How to install graphics card drivers in Ubuntu

ATTENTION ATI/AMD GRAPHICS CARD OWNERS, IF YOU INTEND TO USE UBUNTU (MATE) 16.04, PLEASE READ THE FOLLOWING FIRST!.

EDIT: POSSIBLE SOLUTION FOR SOME WHO HAVE AN AMD CARD ON THE LIST HERE:

http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver–Release-Notes.aspx

See also:

https://support.amd.com/en-us/download/linux

First and foremost, Intel drivers are auto installed and there is no reason to start to try installing any drivers for Intel graphics cards as the best drivers are already installed!.

The following is for Nvidia and AMD (ATI) graphics card owners.

Open > Control Center > System > Software & Updates > Additional Drivers and wait until the page loads:

Window showing list of available Nvidia drivers:

Window showing list of available ATI (AMD) drivers (Not mine btw but the only example I have!):

If you do not see any available drivers for your graphics card, then your graphics card is most likely quite old and you should stick with what you have installed!, if you do see suitable drivers for your GPU, select the driver you want and click on "Apply Changes" and wait for the installer to do its thing. If nothing happens because the tool isn't working, you can manually install the drivers via the terminal (See below for instructions!).

Restart your PC after installing drivers!.

Here are the official links for Nvidia and AMD/ATI drivers:

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

https://help.ubuntu.com/community/BinaryDriverHowto/AMD

Manually install drivers:

Make sure before you start to install the drivers manually that they are indeed the correct ones for your GPU, DON'T TRY INSTALLING AMD/ATI DRIVERS ON AN NVIDIA PC OR VICE VERSA!. THE SAME APPLIES TO INTEL DRIVERS TOO!.

You can easily check your GPU by opening a terminal (Ctrl + Alt + t) and typing:

lspci

scroll down to the bottom of the list and you will find something like this:

which will tell you exactly what make and model of GPU you have on your PC.

Manually adding your drivers via the terminal:

Assuming that available drivers are showing in the Additional Drivers Tool, all you need to make a note of is which has the highest number and its make.

As an example, I will show you the command for installing the Nvidia drivers for my Nvidia GPU PC, open a terminal and type (copy and paste if you like) the following command (AS AN EXAMPLE ONLY!):

sudo apt-get install nvidia-352

which will install the Nvidia driver version 352.63, all Nvidia driver packages end with the version number, nvidia-304, nvidia-340, nvidia-352 and so on!.

If you need the AMD/ATI drivers, (AS AN EXAMPLE ONLY!):

sudo apt-get install fglrx

The above is the Video driver for the AMD Radeon and FireGL graphics accelerators. This package provides 2D display drivers and hardware accelerated OpenGL for X11. (NO 3D ACCELERATION!)

The Radeon driver does have 3D support providing your GPU shows as supported in the list on the following page, double check it!:

https://help.ubuntu.com/community/RadeonDriver

Okay, I installed the wrong driver and now I can't boot/my graphics are shot!:

Don't panic, you can remove the drivers as easily as you installed them!.

Depending on what type of screen you now have in front of you, you will have a couple of options, firstly; if your screen is black and you cannot see anything, try "Ctrl + Alt + Del", log out if you can and restart into "Advanced Settings" (AKA, "Recovery Mode"). If "Ctrl + Alt + Del" doesn't work for you, press "Ctrl + Alt + F2 " and/or "Ctrl + Alt + Backspace" and then "Ctrl + Alt + Del".

Once in Advance Settings (select advanced options for Ubuntu and then the 2nd option again), activate "Network" (using a network cable connection not WiFi) and then go to "root", wait until the messages vanish (you will most likely get a message about networking, just click on "Enter" and say yes if asked!).

Now type the following (using the Nvidia drivers as an example):

sudo apt-get remove nvidia-352

or for the AMD/ATI package:

 sudo apt-get remove fglrx

Once done, you may or may not get a message about restarting, IT IS VERY IMPORTANT TO RESTART AND NOT CLICK ON RESUME, press Ctrl + Alt + Del and let it restart normally and your problem should be gone!.

Restart in "Recovery mode" again and run "network" + "dpkg", restart with Ctrl + Alt + Del again!.

Another method to install or remove problem driver packages.

To install or remove packages, press "Ctrl + Alt + F2 " which will take you to a semi graphical desktop, use your normal login name (username) and type your password (doesn't show in the window or give any indication that it is being noted!).

Enter your username followed by your password and then type your command(s) (the following are only meant as an example!).

Installation:

sudo apt-get install nvidia-352

Removal:

sudo apt-get remove nvidia-352

then restart your system:

sudo reboot

I cannot really comment much further on AMD/ATI drivers as I don't have a card on either of my PC'S!. Maybe someone with one can add more valuable info for this thread!.

Any questions?, feel free to comment!. :smiley:

10 Likes
Weird video issue in 18.04 (Nvidia)
VLC displays black screen
18.04 Blank welcome and software boutique
Caja starts multible instances after login
QT Ambiant Style
Ubuntu MATE 16.04 boots only in recovery mode after update/upgrade
Problems with graphics/error drm:intel_pipe_config
NVIDIA CUDA Installation 16.04 LTS
Installed Skype in 16.04, but won't launch
Steam won't launch 16.04 64-bit
Blurred Icons in LibreOffice
Themes show with large ? And lightened out color?
Monitor sync problems
Introduction Thread
LTS upgrade not working - no graphics
Computer Freeze to a White Screen with Colorful Lines
Geforce 840M and Cuda 8.0 RC Installation
Weird Scrolling Artifacts
nVidia driver update last night, black screen this morining
Unable to change selection in Additional Drivers. Recent Nvidia update perhaps the cause?
Laptop, viewing a video temps go up, are they normal?
My Screen Flicker when installing Ubuntu x64 on my laptop
Corrupted Display on Late 2005 G5[Nvidia 6600 Model/DualCore G5 not DualCPU]
Can't see what I write when creating thread
How to disable Synapse animations?
Ubuntu Mate 16 Intro Load Fail Nvidia
[SOLVED]Monitor undetected
Panel background keeps reverting
Monitors, Panels & My New Insanity Defense Plan
Fading Menu Item names
Video freezes when triying to play a video file. It doesn't when the window is small
Need some help getting hybrid graphics working
Performance with 2+ monitors is low
[16.10] Displays are lost/broken after video card upgrade
Unknown proprietary driver for Lenovo G50-45
Macbookpro 10,1 not working with nvidia card
Welcome Screen and Software Boutique screens are blank
Ubuntu 16.10 mate x2go won't run java apps
Several MONITORS in Ubuntu-MATE 16.04
Ubuntu screen appearing after several hours of PC being idle
How to apply real transparency on the panel
Kodi on PC Intel Pentium IV
Older laptop going into sleep mode when booting and shutting down
Issue with atril in presentation mode
Anyone have duel monitors working Properly in 16.04
Screen Definitions for a legacy monitor
Not minimize desktop 1.16
Recover from system crash
After Upgrade to Mate 18.04 boot problems - not trusted key
Booting issues since Nvidia upgrade...?
Mate 17.10 Mutiny desktop libreoffice 6.02 icons in the dock continue to flash after application starts
Frozen After Login
Nvidia 304 driver
20.04 + nvidia 390 doesn't work for me
20.04: No display found - can't change the driver
Black screen after boot on 18.04 with nvidia
Ubuntu beginners guide, complete how to install and run first update
Random colors while playing movies
Nokia booklet 3g and MATE
16.04 Screen Resolution Question
Xorg crash after wrong nvidia driver change 2008 Aluminium Macbook Pro 4,1
Help Changing Default Depth to 16 [SOLVED]
HDMI on RPi UbuntuMATE
Ubuntu MATE both Onboard Graphics + Discrete Card ? Optimus, tearing, all that jazz
Hello From A New User
Ubuntu MATE not booting
Cannot install or even try Ubuntu MATE 16.04. Graphics problem?
Intel Graphics Question
Video stutters on playback
How to find whats causing certain issues?
Compiz vs. Google Chrome
MPV Not working?

Excellent documentation ! Way to go wolfman :slight_smile:

2 Likes

So... to, finally, verify this for me (and those with similar graphics hardware), I do not need to do anything with my graphics card driver(s)? :relaxed:

Thanks, I have had this question, in the back of my mind for months, @wolfman!

No @mated, if you really; really want the latest drivers, follow this link and add the PPA but there is really no need as the drivers that are installed by default are tried and tested, the PPA drivers may or may not improve your VGA performance!:

If you type:

lspci | grep VGA

you will get a readout like the following which is also Intel on my mini notebook and the reason they don't show when you type lspci is because the info really isn't necessary because the best drivers are already installed!:

1 Like

I shall take your advice, @wolfman, and keep things as they are... 'if it ain't broke, don't fix it' :wink:

1 Like

I have actually found that on some integrated graphics for AMD/ATI, installing proprietary drivers are actually worse then just using the open source ones.

For anyone interested in the reason why Intel does not need any drivers – they’re part of the kernel, Intel work with the open source community to create them, whilst AMD/NVIDIA’s open source drivers are generally driven by community efforts.

2 Likes

Congratulations documentation, excellent tips.

2 Likes

Just for anyone who cares, I installed the drivers for my Nvidia 980ti by downloading the driver from Nvidia and then installing, using terminal in root, with sh. I’m running Ubuntu MATE 16.04.

sh NVIDIAxxxxxx.run --no-x-check

The --no-x-check is necessary since you cannot install while X server is running (the gui). Not everyone likes to risk running in root, though. Still it is working for me so far, if any problems come up I’ll be sure to post.
If you are unsure about root, don’t use it.
Any questions welcome.

1 Like

i have a query LordBaronMarshall sir ,plz help i am getting this error :—[email protected]:~$ glxinfo
name of display: :0.0
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Segmentation fault (core dumped)
i am using ubuntu 12.04 and my graphic card is vga intel .thanx alot in advance.

Hello anchal_kumari

Please post the terminal output of:

inxi -b

Thank you

inxi: command not found

Sorry, my mistake. That command is not in 12o4. I was trying to find out what your running. Go this way:

echo $DESKTOP_SESSION && update-alternatives --get-selections | grep x-window-manager && lspci | grep VGA

…upgraded to “UM 18.10”

before login at boot, boot freezes 40 seconds, after that error message:

PKCS#7 signature not signed with a trusted key
PKCS#7 signature not signed with a trusted key
PKCS#7 signature not signed with a trusted key

after that mate boot into login.

In LogFile-Viewer:
kernel: [ 42.991900] nvidia: loading out-of-tree module taints kernel.
kernel: [ 42.991907] nvidia: module license ‘NVIDIA’ taints kernel.
kernel: [ 42.991908] Disabling lock debugging due to kernel taint
kernel: PKCS#7 signature not signed with a trusted key

in UM 17.04 I don’t have this error on boot.

Some Idea to fix it without uninstall the nvidia driver 340?

Hi @mate2go,

leave the 340 package installed and install the following package (or at least try it), the terminal command (Ctrl + Alt + t) is as follows:

sudo apt install nvidia-driver-390

This is on the assumption it will work for you???. :smiley:

I’ll try it in the next days… maybe these will work, but I have not tried it yet.

sudo su

openssl req -config /etc/ssl/openssl.cnf -new -x509 -newkey rsa:4096 -nodes -days 36500 -outform DER -keyout signing_key.priv -out signing_key.der

openssl x509 -inform der -in signing_key.der -out signing_key.pem

sudo mokutil --import signing_key.der

reboot & enter mok-key

sudo cat /proc/keys

download nvidia-340_x64 (last)

copy autoconf.h (/lib/modules/4.15.0-20-generic/build/include/generated)
to
/usr/src/linux-headers-4.15.0-20/include/linux
/lib/modules/4.15.0-20-generic/build/include/config

These two files “autoconfig.h // auto.conf” should be: include/linux/autoconfig.h and include/config/auto.conf

strg+alt+F2

login

sudo service lightdm stop

Path: cd /nvidia

sh ./NVIDIA-Linux-x86_64-340.106.run -s
–module-signing-secret-key=PATH_to_private_KEY/signing_key.priv
–module-signing-public-key=PATH_to_public_KEY/signing_key.der \ --no-unified-memory