Applet positions on panel change with resolution

Hi All,

I have come back to the MATE desktop after a few years (since GNOME ditched it and it was too much for me at the time to keep everything in GNOME2/Mate), and things have certainly improved a lot (even compared to GNOME2).

Like many people, I only use it on a laptop now. I have kept much the traditional MATE appearance, including having the applet/icons aligned on the right side of the top panel next to the default clock. I have aligned them to my liking with the laptop screen and locked them, however they seem to jump all over the place when I connect to an external monitor (at work, and keeping the lid closed) that allows a higher resolution.

I see from previous posts as old as 6-7 years such as this one:

that I am not alone, however the issue is seem to be brushed aside and closed without resolved multiple times.

Does anyone know of a workaround (aside of not having anything there) for this issue?

Thanks in advance

The quickest workaround I would try is to (on the laptop screen that you like the look of) right-click on each of the items on the panel and click the box for "Lock To Panel". I don't know if you have already tried it, but that is the first thing that comes to mind.


Thanks for your advice, and yes I have locked them and it still happens

The easiest way to deal with your panel objects is to align them from the left, I'm assuming that you use the traditional layout here. When you use a larger monitor, all the objects you have placed in your top panel will be rearranged according to their distance from the Applications Places System menu.

To see the distance numbers, open the dconf Editor and go to org--> mate--> panel--> objects--> object-0 through whatever. Each object has a distance number that is from the left-most point on that panel.

I see this behavior when I work on other people's computers and from the rearranging, I know that their monitor is wider than anything that I have.

Good luck jasonyctam.

Thanks for the suggestion.

I have noticed (aligned from left) by the way that they have moved and have given it a try. Unfortunately that does not fit the liking of the stubborn me, and kind of kills the point for me to move back to MATE, which theoretically is the ability to configure the desktop to my liking.

So the hunt continues....

I've had my own battles with the top panel and its' objects. A suggestion might be to have the panel as you like it and use MATE Tweak (System, Preferences, Look and Feel, MATE Tweak) to save your upper panel as, say traditional-1. Plug in your larger monitor, unscramble your top panel to your liking and save it as traditional-2.

When I just did that, I 'forgot' to lock in place all those icons I had moved to the far right. Making the 1280x800 screen the primary again, all the far right icons moved left as they needed to. Its a nice trick, you should try it. I left all the far left icons locked to their position by the way.

Edit: So the key to this working for you is to arrange your panel when your larger monitor is primary and save it under some name but do not lock anything except the leftmost object or objects. I for instance kept my clock and a shutdown button locked in place, far right. I had to move other icons and a notification area icon over to the right but left them unlocked. Saving the larger layout is insurance against having to spend precious time doing the same thing over and over.

Thanks, that sounds to be a good enough workaround, for now :slight_smile: