Apt dist-upgrade crashes GUI two times .

Seem to be into a "rough patch" with U-MATE lately . . . again running apt dist-upgrade in GUI console causes crashing of GUI.

Bug report filed . . . don't know if this relates to the "Xorg crash" thread in 20.04 . . . . https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1892522

Running a standard "apt dist-upgrade" in U-MATE 20.10 via GUI console & part way through suddenly the screen flashes black and a brief TTY-like dmesg data shows "[Failed] and a bunch of data before going black again . . . . Seems like the GUI was crashed . . . . After a minute the mouse cursor came back and then the log-in window.

I logged in and saw the "error" applet up on the toolbar . . . saying "possibly unmet dependencies" . . . launched the console again and it said, "dpkg was interrupted, run 'sudo dpkg --configure -a'" . . . so I ran that, and a few errors on "libreoffice" showed up . . . it was running through the items again . . . and then the same crash of the GUI happened again . . . ???

Opened synaptic and it says:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Forgot to mention, this is in 20.10 . . . . Third time isn't a charm . . . .

Ran "configure" and then "fix broken install" . . . the ran thru apt dist-upgrade and it appeared "OK" . . . then I ran autoremove and autoclean and again ran apt dist-upgrade . . . it showed "52 packages" to upgrade . . . half way through again the GUI crashed into blackness.

This time took a full minute before mouse came back . . . and back into GUI . . . .

Is it virtual machine?
Which do you use - QEMU, QuickEMU, VirtualBox? With which video driver?

Also please share the result if you use dumb TTY as follows:

  1. Ctrl+Alt+F1 (or RightCtrl+F1 for VirtualBox)
  2. login
  3. run sudo apt update
  4. run sudo dpkg --configure -a
  5. run sudo apt install -f
  6. run sudo apt dist-upgrade

Do you have PPAs in the system?

Please share the output of below command

grep -ir ^deb /etc/apt/ --include=*.list

Do you have obsolete packages in the system? Run

sudo apt install aptitude
sudo aptitude search "~o"

and share its output.

I'm running UM 20.10 in virtualbox 6.0 with VMSVGA video driver and do not have any issues.

1 Like

I just booted into 20.10 beta and ran sudo apt update and then sudo apt dist-upgrade in terminal and got no crashes, no broken package upgrades. Unable to replicate your situation.

1 Like

This is not a virtual machine. I have a PPA for "mkusb" but no errors reported on mkusb. There has been an error for "bcmwl-kernel-source" for awhile but I don't need wifi on this machine.

The only "non-stock" issue is I have both "devel" & "groovy" in the apt sources list, trying to get my ubuntu install to be somewhat "rolling" and possibly that pulls in conflicting packages??

I booted back into MATE and into a TTY and ran your list of commands . . . I don't know how to copy/paste from the TTY, so back in the GUI I again ran your "grep" and "aptitude" commands. Looks like there are residuals left over from when I had ticked the "pre-release" box recently, and that brought in "5.8 kernel & packages" that had a similar "crashing of GUI effect" . . . .

$ grep -ir ^deb /etc/apt --include=*.list
/etc/apt/sources.list.d/mkusb-ubuntu-unstable-groovy.list:deb http://ppa.launchpad.net/mkusb/unstable/ubuntu groovy main
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel main restricted
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel-updates main restricted
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel universe
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel-updates universe
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel multiverse
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ devel-updates multiverse
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu devel-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu devel-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu devel-security multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu groovy universe main
:~$ sudo aptitude search "~o"
[sudo] password:
idA libcdio18 - library to read and control CD-ROM
i A libprocps7 - library for accessing process information
i A linux-5.4-headers-5.4.0-14 - Header files related to Linux kernel versi
i A linux-headers-5.4.0-14-generic - Linux kernel headers for version 5.4.0 on
i A linux-headers-5.4.0-9 - Header files related to Linux kernel versi
i linux-headers-5.4.0-9-generic - Linux kernel headers for version 5.4.0 on
i A linux-headers-5.8.0-12 - Header files related to Linux kernel versi
i A linux-headers-5.8.0-12-generic - Linux kernel headers for version 5.8.0 on
i linux-image-5.4.0-9-generic - Signed kernel image generic
i A linux-modules-5.4.0-9-generic - Linux kernel extra modules for version 5.4

I can't reproduce the crash. Changing from groovy to devel does not produce it.
But I see that bcmwl-kernel-source is not installable.
It is bug 1878045.
It may cause other problems with your upgrade process.

Try to use solution from the comments to above bug-report:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install broadcom-sta-source
sudo apt-get install broadcom-sta-dkms
sudo apt-get install broadcom-sta-common

and then resume the dist-upgrade with

sudo apt-get dist-upgrade

Which Apport Error reports do you have?
Add output of

sudo ls /var/crash

Thanks for the reply . . . I had to reboot out of U-MATE . . . but "apt-get"??? We are rolling back to "apt-get"???

PS: I've done numerous "apt" updates/upgrades with this "bcmwl" problem showing as error . . . without it crashing the GUI . . . ??

removing the one package brought an error:

Removing bcmwl-kernel-source ( ...
Removing all DKMS Modules
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.137ubuntu10) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sdc9
I: (UUID=f9ae531f-ec45-4a13-a75d-d3fd4cd80fe0)
I: Set the RESUME variable to override this.
(Reading database ... 311279 files and directories currently installed.)
Purging configuration files for bcmwl-kernel-source (
) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.137ubuntu10) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sdc9
I: (UUID=f9ae531f-ec45-4a13-a75d-d3fd4cd80fe0)
I: Set the RESUME variable to override this.
Error: Timeout was reached

The rest ran through w/o issue . . . using "apt" . . . . The last command:

$ sudo ls /var/crash

Seems like I was able to now run through apt a couple of times and no crashes, so something has been improved . . . . On today's update/upgrade it showed the standard errors that it has since changing the sources list to try to catch "devel" and "groovy" . . . but the upgrades went through w/o further error.

Reading state information... Done
7 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Conflicting distribution: http://security.ubuntu.com/ubuntu devel-security InRelease (expected devel-security but got groovy)
W: Conflicting distribution: http://us.archive.ubuntu.com/ubuntu devel InRelease (expected devel but got groovy)
W: Conflicting distribution: http://us.archive.ubuntu.com/ubuntu devel-updates InRelease (expected devel-updates but got groovy)
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
gir1.2-ayatanaappindicator3-0.1 libayatana-appindicator3-1 libgdbm-compat4
libgdbm6 libxapian30 libxt6 mate-applet-brisk-menu
7 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Don't think I'm out of the woods on whatever is happening with my 20.10 install. Today, booting from grub the screen went black and stayed that way for perhaps 2 minutes?? a relatively long time . . . then the many lines of "FAILED: to start process . . ." showed up briefly . . . then back to black . . . then the cursor shows and the log in window . . . but it took another few seconds before the password window would appear . . . .

I have an install of Lu groovy in the same drive, I'll be checking to see whether it feels "zippier" than U-MATE . . . seems like some "distortion" has worked its way into the U-MATE system . . . that isn't un-distorting itself . . . ????

[edit: A bit later I ran an apt and it pulled 93 to upgrade, 37 new, 1 to remove, ran through that, logged out, the what must be the TTY still showing the "Failed" lines flashed, then to log in window, no green background, instead it's black . . . when I logged in again the time applet was gone from the toolbar. Decided to reboot to Lubuntu 20.10 . . . got an "api-registry still running" error, took several reclicks to get the machine to reboot . . . .

Selected Lu ini Grub and in about a minute we are logged in . . . . Same HDD, same more or less system . . . except Lu is "Plasma" based . . . .

Problems continuing with my U-MATE install of 20.10 . . . very long boot times, and in the TTY there is a large "FAILED to start processes" . . . . This morning it took maybe 3 minutes to get to a log in window, but the "log in" window was upper left corner . . . it was like in the TTY where it was asking for user name, rather than already "knowing" and just wanting the password. I entered the password . . . then realizing that it wasn't going to accept my password as the user name . . . I hit the power button . . . the TTY with the large "FAILED" line after line showed up . . . before shutting down . . . .

[edit: After I posted this I ran apt and it brought back 126 packages o upgrade and some to autoremove . . . . Also I tried to get into a TTY and it was filled with the "Failed" lines, I tried each of them--all showing the same data. I ran the upgrades and then autoremove showed at the end:

BlockquoteProcessing triggers for desktop-file-utils (0.24-1ubuntu4) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.64.4-1) ...
/usr/share/glib-2.0/schemas/org.ayatana.indicator.datetime.gschema.xml:4:1 Erro
r on line 4 char 1: already specified. This entire file h
as been ignored.
Processing triggers for libc-bin (2.31-2ubuntu1) ...
Processing triggers for man-db (2.9.3-2) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...

About to restart to see if anything changes . . . .

Just to update . . . running the update/upgrade after I posted before did seem to clear the TTY up, the "Failed" endlessly streaming seems to be gone . . . and I could log in to the TTY.

Boot up seems a little faster, but when the log in window loads the "error" "clang" sound sounds . . . but there is no error "splotch" signaling a crash report . . . . and it still seems to be asking for the user name & password even though there is only one user.