Atril failing to display epub files on 18.04


#1

Atril fails to open EPUB files on 18.04. When an epub file is opened from the file manager atril opens and displays the table of contents for the book but the book itself is not displayed, and the loading symbol in the top right corner is not displayed like it is for heavy pdfs. This used to work maybe even with 18.04, I was just wondering if someone else had problems and if there is a workaround


#2

I just tried this with one of the free ebooks from Baen (https://www.baen.com/download/index/owned/id/41832) and it only displays the cover and the ToC but everything else is blank.
On the command line I see lots of errors like this:

(atril:2644): Gdk-WARNING **: 18:52:37.875: ../../../../../gdk/x11/gdkwindow-x11.c:5579 drawable is not a native X11 window

(atril:2644): AtrilView-WARNING **: 18:52:37.879: Error loading data from file:///tmp/atril-2644/On_Basilisk_Station.epubW22MVZ/obs_split_024.html: Frame load interrupted

Launchpag bug: https://bugs.launchpad.net/ubuntu-mate/+bug/1811267


#3

I have just tested more traditional EPUB - https://bookdown.org/yihui/bookdown/bookdown.epub on clean installations of Ubuntu MATE 16.04 LTS and Ubuntu MATE 18.04 LTS.
It renders normally. Moreover your example EPUB renders normally.

But on my main laptop with 16.04 and manually installed Adobe Acrobat Reader (9.5.5-1precise1 package at 9.5.5-1precise1 version) and OpenJDK it fails as you wrote.

Consider to (maybe temporary) to use one of Okular, KCHMviewer or ebook-viewer from Calibre package.


#4

I tried with a fresh profile and there it worked. So I assume something about my user profile is bugging atril.
Does anyone know where the atril config is stored?
It even remembers the last page I had opened even when deleting all files containing atril in my home dir, and resetting everything below org.mate.Atril in dconf-editor.
Does anyone know how to truly reset the atril settings?


#5

I used strace to find out which files in my home dir were opened by atril and deleted these:

~/.local/share//mime/mime.cache
~/.local/share/recently-used.xbel
~/.local/share/gvfs-metadata/

Not sure which of these it was, but it works now. :slight_smile:


#6

I deleted the mime.cache file and it seems to work