Audio Output Mono instead of Stereo (Ubuntu 18.04.1 - RPi)

Honestly, I don't really know anything about PulseAudio or ALSA or much about Ubuntu actually, I've just done lots of Googling and eventually found something that worked.

I use VLC and Audacity, and there's an option in both of those programs to use ALSA, so I did that, but a big problem, Firefox doesn't support ALSA. I don't really know what to do about that, switch browsers? As long as VLC and Audacity work in stereo I'm okay with it.

1 Like

Thank you! That works perfectly for me

I've finally got PulseAudio working in stereo mode. For some reason udev auto detection is not working correctly so it needs to be turned off and instead alsa module should be loaded manually.

So the solution is: comment out these lines so that they look like:

 #load-module module-udev-detect tsched=0 


#load-module module-detect

and uncomment the following line:

load-module module-alsa-sink  tsched=0

Then run:

pulseaudio -k

Pulseaudio should respawn. If it doesn't, then run:

pulseaudio -D