Audio Output Mono instead of Stereo (Ubuntu 18.04.1 - RPi)

installation
audio

#1

Ever since I updated my Pi 3 from 16.04 to 18.04, my audio output has gone from Stereo to Mono. I’m not sure if anyone else has experienced this or not, but I kinda would like my stereo sound back! :innocent:

Does anyone know how to do so? I’m not that well versed in *nix hardware manipulation. Thanks!

I’m attaching the dumps of: uname -a, lsb_release -a, and pacmd list-sinks|grep name below:

Linux strauss 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l armv7l armv7l GNU/Linux No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic name: <alsa_output.0.analog-mono> alsa.name = "bcm2835 ALSA" alsa.subdevice_name = "subdevice #0" alsa.card_name = "bcm2835 ALSA" alsa.long_card_name = "bcm2835 ALSA" device.profile.name = "analog-mono" alsa.mixer_name = "Broadcom Mixer" device.icon_name = "audio-card"


#2

For the pacmd command output, my 16.04 gives analog-stereo in the name and profile.
Perhaps its something in /boot/config.txt?
Derek


#3

This may not be much help but hopefully will point someone in the right direction. I have a Z83 board (Atom) and had the same problem with a rt5651 device (though I started on 18.04, did not try 16.04). In that case the manufacturer’s site had been recommending code from here https://github.com/plbossart/UCM.git, which apparently worked at one time (so maybe 16.04). The code there worked, but caused mono not stereo output. I found that the plain distro code in 18.10 (maybe 18.04 have not tried that again yet) worked without modification.

My point is not to try 18.10, but rather that I think some code has been floating around possibly since 16.04 that in 18.04 causes mono output. Sometimes. At least for me. You might investigate the code in the vanilla distro (look in /usr/share/alsa/ucm perhaps) against what’s in the pi distro you are using. Also if present asound.state in /var/lib/alsa.

I did not try to figure out what was wrong in mine, I just stopped using the flawed code.

Again, this was Z83 not Pi, so a lot of differences, but offered FWIW. And so you know you aren’t alone. :slight_smile:

Linwood


#4

Yes @dandnsmith, I know that 16.04 does stereo. The problem appeared with the install of 18.04… If it is a config.txt issue then I wouldn’t know where to begin.

@Linwood-F, I’m not looking at 18.10 but 18.04. Something changed during the upgrade, and I don’t care who… I just want to see it work correctly again… LOL!


#5

You might try running the 18.04 “live” install kit from USB, and see if the upgrade propagated some files that with the new 18.04 code are causing it, as that would give you a clean config un-altered by anything from your 16.04 system. If that works, you can work backwards perhaps and see what changed in those files (it’s likely only two or a few, in the first folder they will mimic the name of your sound device, in the second it is just asound.state but that’s less likely).

And if it fails in 18.04 clean, maybe open a bug report.

Take all this with a large grain of salt – I know almost nothing about alsa and pulse, just what I scrambled to figure out when mine went south a few days ago with mono. Hopefully someone more knowledgeable may show up and educate us both.


#6

@Linwood-F,

There’s an 18.04 install image that will work off USB for the Raspberry Pi? I was under the impression that there’s no means of getting 18.04 (or 18.10) for the Pi, short of doing an upgrade from the command line. Please elaborate if many of us are mistaken in that understanding…

Thanks


#7

Sorry, I was running on a Z83, I do not know if you can run live on a rPi from the USB.


#8

You can install via the debian/text installer. See AArch64 on Raspberry Pi 2 (rev 1.2), 3B, 3B+ . On that thread there is also a live installer for xubuntu arm64. And an image for armhf.