Audio Output Mono instead of Stereo (Ubuntu 18.04.1 - RPi)

Ever since I updated my Pi 3 from 16.04 to 18.04, my audio output has gone from Stereo to Mono. I’m not sure if anyone else has experienced this or not, but I kinda would like my stereo sound back! :innocent:

Does anyone know how to do so? I’m not that well versed in *nix hardware manipulation. Thanks!

I’m attaching the dumps of: uname -a, lsb_release -a, and pacmd list-sinks|grep name below:

Linux strauss 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l armv7l armv7l GNU/Linux No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic name: <alsa_output.0.analog-mono> = "bcm2835 ALSA" alsa.subdevice_name = "subdevice #0" alsa.card_name = "bcm2835 ALSA" alsa.long_card_name = "bcm2835 ALSA" = "analog-mono" alsa.mixer_name = "Broadcom Mixer" device.icon_name = "audio-card"

For the pacmd command output, my 16.04 gives analog-stereo in the name and profile.
Perhaps its something in /boot/config.txt?

This may not be much help but hopefully will point someone in the right direction. I have a Z83 board (Atom) and had the same problem with a rt5651 device (though I started on 18.04, did not try 16.04). In that case the manufacturer’s site had been recommending code from here, which apparently worked at one time (so maybe 16.04). The code there worked, but caused mono not stereo output. I found that the plain distro code in 18.10 (maybe 18.04 have not tried that again yet) worked without modification.

My point is not to try 18.10, but rather that I think some code has been floating around possibly since 16.04 that in 18.04 causes mono output. Sometimes. At least for me. You might investigate the code in the vanilla distro (look in /usr/share/alsa/ucm perhaps) against what’s in the pi distro you are using. Also if present asound.state in /var/lib/alsa.

I did not try to figure out what was wrong in mine, I just stopped using the flawed code.

Again, this was Z83 not Pi, so a lot of differences, but offered FWIW. And so you know you aren’t alone. :slight_smile:


Yes @dandnsmith, I know that 16.04 does stereo. The problem appeared with the install of 18.04… If it is a config.txt issue then I wouldn’t know where to begin.

@Linwood-F, I’m not looking at 18.10 but 18.04. Something changed during the upgrade, and I don’t care who… I just want to see it work correctly again… LOL!

You might try running the 18.04 “live” install kit from USB, and see if the upgrade propagated some files that with the new 18.04 code are causing it, as that would give you a clean config un-altered by anything from your 16.04 system. If that works, you can work backwards perhaps and see what changed in those files (it’s likely only two or a few, in the first folder they will mimic the name of your sound device, in the second it is just asound.state but that’s less likely).

And if it fails in 18.04 clean, maybe open a bug report.

Take all this with a large grain of salt – I know almost nothing about alsa and pulse, just what I scrambled to figure out when mine went south a few days ago with mono. Hopefully someone more knowledgeable may show up and educate us both.


There’s an 18.04 install image that will work off USB for the Raspberry Pi? I was under the impression that there’s no means of getting 18.04 (or 18.10) for the Pi, short of doing an upgrade from the command line. Please elaborate if many of us are mistaken in that understanding…


Sorry, I was running on a Z83, I do not know if you can run live on a rPi from the USB.

You can install via the debian/text installer. See AArch64 on Raspberry Pi 2 (rev 1.2), 3B, 3B+ . On that thread there is also a live installer for xubuntu arm64. And an image for armhf.

Same happens to me. After upgrade the pi from 16 to 18, only mono output. And no BT.
I don’t know if is related but there is some problem with raspberrypi-sys-mod. It doesn’t exist in 18.

@graf_eberstein - HI, Where you able to get this resolved? I did a fresh new install 4 days ago and have exactly the same MONO problem. Did you also have other problems i.e… crackling interrupted sound?

I have gone 15 rounds with this thing and it has kicked my bu…

Please let me know if you found anything.

No. I don’t have a resolution to the audio output issue. However, I think I saw something somewhere that it is a driver issue. But I must emphasize that I’m unsure; even if I heard those very words, I may have done so pertaining something else entirely…

So... nobody found a solution about this problem? I, too, have a mono output sound from HDMI. Pretty disappointing when listening to music or watching a movie.

I have the same issue with my install . I have resolved it by using a USB to audio conveter . Pithos is is not out putting audio , I also snap installed Strawberry with no audio out. audacious is working in mono but output stereo with the converter.

1 Like

@jlxb I've fixed the problem of choppy/distorted sound on my rpi, it's a problem with PulseAudio.According to,
you're going to want to add tsched=0 to the line load-module module-udev-detect in /etc/pulse/

load-module module-udev-detect tsched=0

Another problem I had was a delay for the sound to begin to come out, and I fixed that by commenting out the line load-module module-suspend-on-idle in /etc/pulse/

Unfortunately, I still have this problem with the mono sound. I don't know what's wrong with that. Sorry.


Wow! Thanks! Some day I'll have to dig that pi out of the drawer I threw it into.

I'd like to get this fixed too

After lots of searching and messing around, I think I've sort of done it. The problem seems to be that the pi is meant to use ALSA but Ubuntu wants to use PulseAudio. I've found this guide: It says to open /etc/pulse/client.conf, then uncomment (remove the ; character) and edit the following line:
; autospawn = yes
autospawn = no

This works, but since Ubuntu is built to work with PulseAudio, things like the volume controller will just show mute and you can't change it. But I've also found this:, it's a guide on how to make ALSA default but it says to change so many things I'd rather just keep it the way it is now until it starts to really bother me. If you really want to make all those changes, go ahead, and let me know how it works.
I hope this helps.

EDIT: Found out that even though alsamixer thinks it's still mono, you can control the volume with it.

1 Like

I would rather be using mate, but if audio is broken then I'm going to have to stick with Raspbian.

Want to note that by default, no hardware shows up in sound preferences, hardware. When I make the changes to that scks details (a couple above) then the delay is indeed gone, and "built-in audio" (mono) does show up in preferences, hardware.

I dunno what the official way of reporting this is, but if someone points it out to me I will.

I reported this bug here:

You seem to know a lot more about this so please do go ahead and fix or add anything I've reported incorrectly, thanks for your work on this.