Black screen after boot on 18.04 with nvidia

HI @mspadaru,

see this section "Okay, I installed the wrong driver and now I can't boot/my graphics are shot!" of the following link:

I have an Nvidia card and it is working fine on UM 18.04 without the need for any interaction from me apart from installing using the Additional Drivers tool!. :smiley:

As for having to repeat the process you could try

chattr +i /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf

This will make the file immutable and thus updates should not overwrite it. Might require sudo but not sure right now.

It looks like this bug may only affect people with hybrid graphics or multiple GPUs and a BIOS that doesn’t allow the selection of a primary GPU. I’ve got a Dell Inspiron 7567 with an nVidia 1050 Ti, and I get the black screen after booting with the nVidia 390.48 driver, although I can use the nouveau driver in 18.04.

According to the bug report mentioned above, the 390.48 version is supposed to include the fix, but it certainly hasn’t resolved the problem for me. I don’t have a /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf file to edit. I do have a /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf that has the “Primary GPU” “Yes” option in it, but it’s overwritten every time by gpu-manager, so commenting that line out doesn’t help.

Is there something else I could be doing to get the nVidia driver to work now that an updated version of the driver has been released?

Anyone experiencing this issue please mark yourselves as being affected by the following bug.

Better yet, please collect dmesg, /var/log/Xorg.0.log and /var/log/gpu-manager.log and post your comments. There is someone investigating and more data will help.

1 Like

I hear a fix has been found. Should be available for testing tomorrow. Big thanks to Entroware for stepping up and providing a heap of debug data.


I tested the fixes. Looks good.

1 Like

I just upgraded to 18.04 from 17.10 with nvidia 384 installed which was upgraded to 390 and I was greeted by a black screen. So I uninstalled nvidia drivers and rebooted. Still a black screen now with two lines. The first an error with aufs aufs_fill_super and the second overlayfs missing 'lowerdir'. So I reinstalled 17.10 (no nvidia this time) and upgraded again and it worked. Any ideas?

Hi Daniel,

what are your software sources download location settings like, that may have something to do with it???:


I use all the sources except for source code under “Ubuntu Software” and none under other software. I think some of the 17.10 sources carried over. Server is Austria (that’s where I am). Additional drivers has never and still does not show available drivers for my laptop (a Lenovo W550s with Nvidia Quadro k620m). I had this issue before but everything worked well under 17.10 just by installing the 384 drivers. It seems these are not available in 18.04 and 390 breaks the drivers. This quite unfortunate. I tried the fix that @wimpy posted but the file did not exist. Instead a 11-nvidiaprime.conf or so did and I tried to comment out the primary gpu there but that did not help. Reinstalling Nvidia after the upgrade also did not work.

Reading your comment I tried this again but after commenting out Primary GPU I also ran sudo chattr +i 11-nvidia-prime.conf so it cannot be overwritten. This seems to work but now when I run glxinfo I get the following error:

Error: couldn’t find RGB GLX visual or fbconfig

I changed back to intel with primeselect intel and glxinfo works fine again.

nvidia-prime 0.8.8 ist supposed to fix this will test and report back here

Indeed, nvidia seems fixed. I had a problem upgrading libnvidia-compute though. This could be fixed with the fix broken dependencies command in the boutique.

Sometimes the system doesn’t write the Nvidia config file correctly. It’s a Nvidia drivers issue I reckon.
It is always safe to go to the terminal and execute “sudo nvidia-xconfig” to write the config file manually after the Nvidia drivers change (changing from xorg to Nvidia proprietary)

Hi Daniel,

change it to “Main Server” and run updates again. :smiley:

It seems fixed for now but will do that anyways. Thanks. :slight_smile:

1 Like

I got blank screen after added a second GPU. Everything went back to normal after setting PrimaryGPU to no.

@Wimpy I went to the site, but being new I did not understand how to apply the fix.
Can you please tell me step by step what I have to do?!.
Im running with asus dual grpahic card intel +nvidia 850M wand Actually I removed nvidia driver.

This is broken again ???? i have what seems like this issue but i have newer version that bugfix indicate ?

Hmmm.. May be hardware dependent? I have an XPS 15 with a 1050 card, I booted using nouveau.modeset=0 acpi_rev_override=1 to avoid an input lock due to an issue in the video card (?), other than that a bare metal install of 19.04 was flawless for me

if i do this then i can get to login prompt but then when i login it freeze or appear to do so.

before this i would get black screen while hearing the drums sound. and then able to do nothing. (i can ctrl + alt+ f1) and get prompt.

i must:
sudo prime-select intel

without this i cant use computer at all. but its running low rez and i kinda need the nvidia driver.

Is there any kind of loc i can provide to find out if this is the errror i have or if i am on a wild goose chase

it seems that after using the
nouveau.modeset=0 acpi_rev_override=1

i can now get to the login screen without using it. but it now freeze when i login.

if i try ctrl+alt + f1 then it unfreeze at send me back to the login screen to chose user and try again. (endless loop)

so pehaps i am haing a different issue now ?