Black screen after boot on 18.04 with nvidia


#1

Hello,

I have an ASUS laptop with Nvidia 950M GPU with optimus technology. Ubuntu mate 16.04 runs fine on it.

I installed Ubuntu Mate 18.04 beta 2. On first boot in the new system I did an upgrade and then installed the Nvidia drivers (390) using the “Additional Drivers” tool, then rebooted. After reboot I only see a black screen. It is not frozen or crashed, it just doesn’t display anything (I can tell since I hear the sounds and it responds to commands).

I also tried 4 different fresh installs of Ubuntu Mate and using Mate Tweak, I changed the Window Manager to each of the 4 options (Compiz, Marco - no compositor, Marco - software, Marco - GPU ) before installing the Nvidia drivers. I tried with and without automatic login on boot, since I thought the login screen might be the one causing problems. I tried kernel options: “nouveau.modeset=0” and “nomodeset”.
The result was the same.

This is not an issue in Ubuntu (Gnome). I also tried Kubuntu and Ubuntu-budgie, and on both this problem only affects the login screen. If I enable automatic login on boot, they work fine. (Mate doesn’t work even with auto login)

Do you have any suggestions what I can try next?
Cheers!


#2

I have an Asus laptop with Geforce 760M, but have no problems. In my case, I could also choose the older 340 driver. Maybe you have a similar offer.


#3

There are known problem with the nvidia 390 drivers, for a few months now I think. Ideally you would use the Intel drivers, but nouveau seems to work well for me.


#4

I’ve got the 390 drivers working on my XPS 15 today, providing I make the modification outlined in this comment:

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1756226/comments/20


#5

Thank you Wimpy. I booted to the black screen, I switched to a new tty and made the modification. After the reboot I could see the desktop.

However, after an update I got the black screen again and had to repeat the process.
Also, the driver doesn’t seem to be working properly. For instance, if I try to run glxgears, I get the following error message: “Error: couldn’t get an RGB, Double-buffered visual”.
Am I missing something?


#6

HI @mspadaru,

see this section "Okay, I installed the wrong driver and now I can't boot/my graphics are shot!" of the following link:

I have an Nvidia card and it is working fine on UM 18.04 without the need for any interaction from me apart from installing using the Additional Drivers tool!. :smiley:


#7

As for having to repeat the process you could try

chattr +i /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf

This will make the file immutable and thus updates should not overwrite it. Might require sudo but not sure right now.


#8

It looks like this bug may only affect people with hybrid graphics or multiple GPUs and a BIOS that doesn’t allow the selection of a primary GPU. I’ve got a Dell Inspiron 7567 with an nVidia 1050 Ti, and I get the black screen after booting with the nVidia 390.48 driver, although I can use the nouveau driver in 18.04.

According to the bug report mentioned above, the 390.48 version is supposed to include the fix, but it certainly hasn’t resolved the problem for me. I don’t have a /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf file to edit. I do have a /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf that has the “Primary GPU” “Yes” option in it, but it’s overwritten every time by gpu-manager, so commenting that line out doesn’t help.

Is there something else I could be doing to get the nVidia driver to work now that an updated version of the driver has been released?


#9

Anyone experiencing this issue please mark yourselves as being affected by the following bug.

Better yet, please collect dmesg, /var/log/Xorg.0.log and /var/log/gpu-manager.log and post your comments. There is someone investigating and more data will help.


#10

I hear a fix has been found. Should be available for testing tomorrow. Big thanks to Entroware for stepping up and providing a heap of debug data.


#11

I tested the fixes. Looks good.


#12

I just upgraded to 18.04 from 17.10 with nvidia 384 installed which was upgraded to 390 and I was greeted by a black screen. So I uninstalled nvidia drivers and rebooted. Still a black screen now with two lines. The first an error with aufs aufs_fill_super and the second overlayfs missing 'lowerdir'. So I reinstalled 17.10 (no nvidia this time) and upgraded again and it worked. Any ideas?


#13

Hi Daniel,

what are your software sources download location settings like, that may have something to do with it???:

:smiley:


#14

I use all the sources except for source code under “Ubuntu Software” and none under other software. I think some of the 17.10 sources carried over. Server is Austria (that’s where I am). Additional drivers has never and still does not show available drivers for my laptop (a Lenovo W550s with Nvidia Quadro k620m). I had this issue before but everything worked well under 17.10 just by installing the 384 drivers. It seems these are not available in 18.04 and 390 breaks the drivers. This quite unfortunate. I tried the fix that @wimpy posted but the file did not exist. Instead a 11-nvidiaprime.conf or so did and I tried to comment out the primary gpu there but that did not help. Reinstalling Nvidia after the upgrade also did not work.


#15

Reading your comment I tried this again but after commenting out Primary GPU I also ran sudo chattr +i 11-nvidia-prime.conf so it cannot be overwritten. This seems to work but now when I run glxinfo I get the following error:

Error: couldn’t find RGB GLX visual or fbconfig

EDIT:
I changed back to intel with primeselect intel and glxinfo works fine again.

EDIT2:
nvidia-prime 0.8.8 ist supposed to fix this will test and report back here


#16

Indeed, nvidia seems fixed. I had a problem upgrading libnvidia-compute though. This could be fixed with the fix broken dependencies command in the boutique.


#17

Sometimes the system doesn’t write the Nvidia config file correctly. It’s a Nvidia drivers issue I reckon.
It is always safe to go to the terminal and execute “sudo nvidia-xconfig” to write the config file manually after the Nvidia drivers change (changing from xorg to Nvidia proprietary)


#18

Hi Daniel,

change it to “Main Server” and run updates again. :smiley:


#19

It seems fixed for now but will do that anyways. Thanks. :slight_smile:


#20

I got blank screen after added a second GPU. Everything went back to normal after setting PrimaryGPU to no.