Black Screen Issues

Hi everyone,

I've had black screen issues with just about all of my 22.04 installations, including vms, but this one I haven't been able to fix. The video is a ASPEED AST2500 and the MB is an Asrock EPC621D8A server board. Installation went fine and it ran no problem, I did update the kernel and rebooted and I saw the black screen with top left cursor indicatin vidoe driver issue.

I booted from the earlier kernel which was installed originally (a few days ago) but achieved the same result. I realise that a variety of conditions can cause the issue I described, but is there a definitive guide anywhere to resolving? I think I'm going to need to refer to it regularly.


Hi Ian, welcome to the community. :slight_smile:

The AST2500 is a Server Management Processor (a.k.a Baseboard management controller or BMC) which, besides its core tasks, also handles a little bit of video (but don't expect too much from it) and according to the docs it has only 2D GPU capabilities (because: who needs a fancy GPU on a headless server anyway)
So I guess that every os that uses compositing will end up with a black screen.

AFAIK, compositing in Ubuntu Mate is default on so that could explain the issue that you are facing now.

You might have a chance of getting it to run if you disable compositing altogether.
I assume here that the kernel must at least be able to run a bare displayserver (Xorg) on the BMC chip.

When you boot from the UbuntuMate install media, make sure you choose "safe graphics" and try to find out from there what the BMC hardware is capable of.

If it shows you a desktop -> hurray!!

If not: then it probably can't handle the display server and you are bound to live with textmode unless you have the possibility to add a discrete graphics card (and disable the graphics on the BMC)

You also can choose to install Ubuntu Server instead and add a desktop later on.

1 Like

Thanks very much for your reply! Compositing isn't something I'd considered, I'll see if i can disable it as i can get to a terminal. It's likely to work because it was only when i rebooted it when it failed, and i mean rebooted it after rebooting it for the installation. I'd been working on it and configuring kvm for about 4 days before i had this problem, so i know there's a way, what changed is the mystery to me.


in terminal type mate-tweak to load it, then disable the compositor from inside that

Thank you, i wish I'd seen this before i went ahead. My method was more complicated, and while i do have a display, now it's limited to a single resolution.

Deleting the xorg.conf file and switching off compositing worked but now i have no config, and X -configure doesn't populate anything useful. Perhaps i should have renamed the file :weary:

I tried a few xrandr commands yesterday but ran out of time. I did install all drivers using the ubuntu-drivers command so now i just need to make it recognise the chip. Alternatively i could add a pci card that it will know.


I remembered, one of the very first things I do for a new build is to enable Timeshift :slight_smile:

So I restored the xorg.conf from there, and I have a full resolution working display once again.

Thank you for your support and assistance!