Black screen then login screen (Intel GPU)

When I turn on the computer, I see the Grub screen with the options to boot to Ubuntu or Windows, but after choosing Ubuntu I see a black rectangle and it stays like that until I see the login screen.
I know it's supposed to show the Ubuntu Mate logo loading the OS. But I have never being able to see that.
I tried deleting the "splash screen" option in Grub...
Changed this:


To this:


But it didn't make any difference.

I'm adding a couple of pictures so you can see.
(Yes, that's me in the backgound) :grin:

Hi @Gabo,

I’m not certain but I think it is GPU related, it doesn’t happen on my Nvidia rig but does on my mini notebook which has Intel graphics?. :smiley:

1 Like

What kind of graphics you got going on? In terminal:

inxi -G
1 Like

This is what I have:

Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.2.0

Hi @Gabo,

try running your updates again using the following guide and switching your software sources download location.

I cannot say that this will solve the problem as you have an Intel GPU which is the same as mine!:

Hi, thank you for that post. I’m familiarized with must of those steps. I use Ubuntu daily for a few years already. I haven’t take the time to fix this issue, and now that I’m on vacation I’m trying to get it done. :grin:
I have to say I will save that post as a reference for new users, it’s pretty well done.

This is what I have tried so far with no luck...

I updated MATE Desktop to 1.14.1

Then I checked the screen resolution list in Grub:


I changed the resolution in Grub (default was 640x480)

sudo nano /etc/default/grub

To a few from the list, like: 1024x768, 1366x768 (prefered mode), with no luck.

I also changed




At every change I made sure to update grub:

sudo update-grub

I noticed the black rectangle is the same size the command line has when you press C in Grub.

It's pretty weird.

I seen this problem (screenshot#2) for a short while when 16.04 was still in the developmental stage. It did go away for me, but I run nvidia. I think the nvidia fix was part kernel upgrade and a adjustment to the nvidia settings editor. Little help to a intel user :frowning:

Can you verify this in 17.04 with the intel gpu?

My google-fu is pertty good, but I have not located any reports on this.

I think this is a bug and editing grub will have no effect.

I hope other intel users will chime in.

Ok, I was able to fix the problem.
I found the solution here on step 2: Linux Mint - Community

echo FRAMEBUFFER=y >>/etc/initramfs-tools/conf.d/splash

then update...

update-initramfs -u

I can still see the black square but for only 3 seconds, then it goes to Ubuntu Mate logo the rest of the time to finish with the login screen. It looks so much better.


Nice find :slight_smile: :wave:

Hi @anon42388993,

yes, it happens on 17.04 too, I haven't tried @Gabo's fix but will give it a whirl later!. :smiley:

Tri-boot with UM 16.04 & UM 17.04 dev + Windows 10 (all 64 bit) on my Packard Bell mini notebook with Intel GPU. :smiley:

1 Like