Bluetooth error - Quick & Easy Fix, Ubuntu

I found a quick non-techie fix for a Bluetooth glitch that's maybe worth trying first if you have a similar issue or error message.

Today I noticed that the Bluetooth icon was missing from my Ubuntu Mate 20.04.3 installation's Indicator Applet. It had been working perfectly, so I tried starting Bluetooth from the Indicator Applet's system settings and (after a long delay) got this error notification:

Connection to BlueZ failed
Bluez daemon is not running, blueman-manager cannot continue (etc...)

Rummaging the web brought innumerable reports of similar problems and countless complex potential diagnoses and solutions bringing mixed results. Pages down in this such topic was mention of a "cold boot" bringing success.

I tried a Restart on my Blutoothless Dell to no avail. Then I tried a Shutdown (aka cold boot), also joyless. Then I remembered back in the DOS days, how an ice cold boot sometimes worked.

This "Ice Cold Boot" if we can call it that, is what immediately worked wonders:

  1. Shut down.
  2. Unplug PC.
  3. Long-press power button (still unplugged) 10 seconds.
  4. Plug in and power up.

Gleaming in my Panel's Indicator Applet icons was my friendly oval blueman buddy, with the familiar red x in his pocket. I clicked him, clicked Turn Bluetooth On in the popup, and the red x vanished as hoped. I happily sent a test file to my phone. In short, it's working perfectly again. I'm posting this in the hope it's helpful for other Ubuntu users, who'd like to try the simplest, quickest and easiest fix first. The only "hard" part of it for me (after rummaging and finding mention of cold boot), was to dig into the tangle of wires and unplug/re-plug the PC. Well, also remembering the "Ice Cold Boot" trick. Judging by reports I saw during the rummaging phase, this has worked on various versions of Ubuntu though I didn't notice any descriptions of my "ice cold boot" process mentioned. Good luck. :slightly_smiling_face:

1 Like