Bluetooth keyboard not working

I contacted the seller and he tells me it is not compatible with linux, but he does not specify why. What to do?

Whenever you want to buy a device in order to use it on Linux, make sure it is compatible with it in the first place. That will spare you some headaches.

1 Like

Unfortunately linux is very poorly supported. In this case I had not given weight to the indications because bluetooth keyboards are generally supported anyway. This is not the case. Strange however that it doesn't work with linux. Is there anything that can be done or is it useless to try?

Well, I would give some other shoots to that, like maybe :
Checking on the keyboard if there are no windows mode and android mode. Maybe a keyboard combination can control it.

It's only a keyboard, suppose to work :slight_smile: but as @Utsuro says, some vendors like producing strange protocol hardware and this is the trap ...

Keep us updated if you are finding something :slight_smile:

Linux is not «very poorly supported».
There are hiccups with exotic hardware sometimes.
When you're buying stuff that might not be «plug and play» with all the things going on behind the scenes (i.e., a bluetooth keyboard or a soundcard), you might want to stick to the most well known brands (for a keyboard, Logitech, HP, Dell, Lenovo, Corsair, Razer etc...) and figure out first online whether someone has already dealt with it.
If there are 95 people around the world running some piece of hardware, devs might not bother writing a driver for it.
My soundcard, an exotic one, has only been decently supported by the kernel for about a year. It was a bummer, especially since a revamped model came out a few months after I bought it and was usb class 1 (= supported out of the box on Linux). Had I been running Linux at the time, I would have bought something else I guess instead of having to boot the annoying operating system every time I wanted to use it.
Anyway, if Linux is your thing, check online first before buying new hardware.
There are people here every week complaining the newest disposable laptop with Celeron + soldered ram + «slow» emmc doesn't work properly when they could have bought a powerful and maintainable refurbished business laptop perfectly supported on Linux for the same price.


Can you suggest a bluetooth keyboard 100% compatible with linux?

Just look for "Linux bluetooth keyboard" on Amazon and search for "linux" in the user comments.
You should quickly find whether it is compatible with Linux or not.
Logitech K380 should not be a bad pick.


I proceeded to install mate on an external drive from scratch. I tried to plug in the keyboard and it works. The only problem is that it loses the connection after a short period of non-use. Obviously with the installation of mate that I have on the computer there is some software that conflicts with the bluetooth manager. Suggestions on how to understand which one it is? Is there any solution to the connection loss?

Hi :slight_smile: Good news so :slight_smile:

I guess the bt is going to power saving mode. I got similar issue with my mouse.

We already got a discord about that here :

1 Like

I agree, a few minute of research can save hours of frustration. And surprisingly Microsoft Keyboards have usually been Linux compliant for many years. I learned this lesson when buying a Bluetooth dongle for a laptop that did not have Bluetooth years ago.


Unfortunately only partially. The problem on the PC is not solved, I just verified that on a new installation the problem is partially solved. Reinstalling everything is complicated and takes a long time without being sure that there is a real solution.
I also tried to reinstall all the packages for the bluetooth but it was not conclusive.
Any other suggestions?

Hi :slight_smile:
You mean the problem that the bt is going for power saving ?

I didn't make myself clear. The keyboard works, with some power saving problems, on a new installation. On computer installation complete with programs does not activate.
I don't know, for the second case, how to solve. Reinstalling everything takes too long without certainty that this is the real solution.
Do you have any useful tips?

To be sure I understood :slight_smile: :
You got it working on a fresh install of UM on a other computer -keyboard works
On the computer you got originally the issue, the keyboard still don't work.
Did I got it ?
Are those 2 machines different hardware side ?
What version of linux kernel is working / not working ?

PS : I got many issues like device disconnecting without reason on a broadcom wifi / bluetooth combo and finished ordering a intel one from ebay. what bt devices do you have ?

I had the same problem with a mouse. The problem got solved by deleting the mouse from everything (windows10 and ubuntu. Then installed it on ubuntu in the usual way via bluetooth install. It worked! Now DO NOT EVER use the keyboard on windows10, or you are back to square one. My guess is that windows xchanges the device code.
Good luck!


I have seen this too.

1 Like

I have seen the keyboard but it is not backlight (backlit).
Is there a linux-compatible model with this feature?
Thank you.

Can you try this ?

You can try to disable Radio power save editing this file :


wifi.powersave = 2

Recently I got a Thinkpad Bluetooth mouse that was not working at all without this configuration.

1 Like

I tried but it doesn't work. Now I have tried with Ubuntu Mate 20.04 LTS live and the keyboard BT works. I suspect some applications are conflicting with the keyboard BT. Find out what and how it is complicated. In any case, the bluetooth assistance crashes and I send the report, hoping that the developers fix it. It is objectively difficult to understand what is really wrong.

1 Like

I have done numerous tests installing recent versions of Ubuntu Mate and Ubuntu (gnome). In all cases when I installed the Mate version the keyboard, after updates, does not work. With Ubuntu (gnome) instead the keyboard works correctly both with the live versions, and with the versions installed and equipped with all the updates. I do not know what the problem is but now, I think certain, that the problem is with the Mate version. I hope you can sort it out somehow. If you can tell me any tests that I can carry out independently. I also tried the impish beta version of both versions with the same results, both with live, working keyboard, and installed and updated: Mate does not work with Ubuntu (gnome) works. Thank you.