Bookmark from Menu -> Places opens with wrong application

This is kind of weird:

That's a remote folder that I access through SSH on a dedicated server, the bookmark was added in Caja and works correctly when I access it through Caja.
However when I attempt to access it through Menu: Places -> [The bookmark] it tries to open it with Eye Of Mate image viewer for some reason.

Anyone know how I can fix this?

Edit: running on Ubuntu MATE 16.04.1 w/ MATE 1.12.1

I have several sftp:// bookmarks. I don’t think I ever tried the Places menu but it appears to work ok in this 16.04 / Mate 1.14.1.

There is Places -> Bookmarks -> (bookmark) and once mounted, Places -> (mounted-bookmark). I assume this is strictly the latter opening EOM. I was thinking that somewhere, this menu is built with the mounted entry and this is where to fix it with the properties - but dang if I can find it!

1 Like

OK, for some reason there was nothing in that settings window set for "File Manager" before I clicked the list to pick one.

I don't know how that came to be, seeing weirdly there is no way to pick something else now that Caja is set.
Now that Caja is set the Places menu shortcuts work correctly and invoke Caja.
I'm checking this as solved for now because I have no clue how to reproduce. ?_?


I also had a situation where caja was not set as default in preferred applications…as a result, every time i started caja, clementine launched…it also affected the trash folder since it is associated with caja. Selecting caja fix the problem.

1 Like