Boot gets stuck on grey screen and wont continue

So I recently got a Acer TravelMate b117 from a friend. It came with windows 10 pre-installed, but the TravelMate is pretty weak and I prefer most linux distros over windows. So I have tried to install multiple distros kali, arch, and mate. The live environments work fine on ubuntu mate and ubuntu proper, but after installing neither boot, mate gets stuck on a grey screen forever.

Do you know what video card is in that machine?

intel Igpu for the Intel Celeron Processor N3160

I think it might have to do with the fact that the laptop uses an emmc as its main boot drive

Did you disable fastboot from bios?

yes I disabled fast boot/ secure boot, I tried legacy and UEFI. reinstalling between each combination. nothing has worked so far

you said it would boot to the live session? If so boot to the live session and type this command in a terminal and post the output here.
inxi -Fxz

So it boots, so I installed it with uefi enable in the bios, and it didnt boot, but then I changed it to legacy and then it worked fine. Even though installing it with legacy enable in the bios wouldn’t boot. So its working but it was really strange

1 Like

UEFI installs can be tricky at times. Glad you got it going. :slight_smile: