Boot problem after failed upgrade

After a failed upgrade to 20.04LTS I am greeted with a TTY1 screen. After typing my login and password the only way to view the desktop is to type startx. What do I have to do to get back to a normal boot

Maybe try reinstalling lightdm?

3 Likes

Hi :slight_smile:

What was the reason of the failure ? a power issue during the upgrade or a system error message ?

Honestly, I would reinstall again a reliable system, but temporary, you can try sudo apt update and sudo apt upgrade with hopes that apt will fix issues.

Re-installing lightdm solved it thanks

2 Likes

I have no idea i`m afraid, I left it to do itself and came back to a blank screen. All fixed now though

1 Like

Glad it was a straightforward fix!

Since you could boot to a functional terminal, and then log in and start X with startx, seemed like it had to be the display manager...

This worked for me too. Did an 'apt upgrade' and afterward it would only boot to tty1. 'sudo apt remove lightdm' and then 'sudo apt install lightdm' fixed it. Thank you so much!

Great! Glad you're back in the saddle. You probably could have gotten away with:

sudo apt install --reinstall lightdm

But it's all good!