Boot-repair (unable to mount root fs on unknown block (2,0)

I previously installed Ubuntu Mate on my Lenovo X201 using a USB-stick that I got from a friend. Ubuntu was running well but after the installation I couldn’t boot anymore into Windows 10 (basically it went into an infinite loop when I entered my password). I tried to fix this error following the instructions provided here: (2nd option).
However, now I can’t boot my computer at all - not into windows nor ubuntu - and I get this:

I tried changing the boot mode from diagnostics to quick and I clicked “load setup defaults” in the BIOS setup utility - didn’t help.

If I select the USB-stick in the boot menu and try to boot from there I get automatically:[QUOTE]
Missing parameter in configuration file. Keyword: path
gfxboot.c32 not a COM32R image
I typed “live” as suggested in another thread but then I get this and the computer doesn’t react anymore afterwards.

Still very new to ubuntu and slowly getting to know all the terminology, please bear with me.

Boot-repair at the end of it’s run gives you a webpage where it stores the log of the repair. Did you save that page. If so post the output here , it will contain important info on what it did and any errors encountered. This will be of help in trying to help you. If you didn’t save the address you should run boot-repair again and post the out put of that web page.

I’m not sure if I got a log at the end but if there was one, I didn’t save it.
However, I can’t run the boot repair again, my computer doesn’t boot anymore - neither in ubuntu nor in windows :frowning:

All the information I have is written in the first post…
Can someone help me?

Using the information that you posted, I searched on the term “gfxboot.c32” and the most helpful article was this -

Please try both answers, take notes and report back on what happened. We need as much information as possible in order to assist you in resolving your situation.

Good luck elolitta.

Well, I already tried that. But when I type “live” or “install” I get this:
“…Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)”

I actually think that this article describes the issue:
But I don’t really understand the resolution:

open the kernel configuration:
root #make menuconfig