Booting / odd message on MacBook

I run Ubuntu Mate 20.04 in a MacBookPro mid-2009. Very happy with it, I have had no problems at all.
However, since yesterday or the day before I have the following message on booting the machine:

I do not remember making changes in the computer other than routine updatind. The MacBook now takes a bit longer to boot. Otherwise, nothing seems to be wrong with it. There must be an error somewhere and I would very much like to repair it.

Suggestions? Thanks in advance.

Hi :slight_smile:

This is a error not related to the kernel. Something is not set up correctly in the EFI bios.

I found that statement :

"Just remove shim/shim-signed/mokutil, and make sure you also deleted /boot/efi/EFI/*/shimx64.efi, then this problem goes away. It's not related to linux kernel."

here :

Please try :slight_smile: but be careful inside there. Read all before acting :slight_smile:

Thanks. I did follow your advice and read it all. I didn't act, though. I am not very comfortable with the idea of dabbing with the bios and then I found the following statement further down in the forum:

I've got the same issue on my Macbook Pro early 2008. Deleting /boot/efi/EFI/ubuntu/shimx64.efi doesn't help at all.

"Solution": Press "alt" when booting the macbook. Select "Boot from next target" and your system should boot by showing the error message. Alternatively, do exactly the same by starting a LIVE USB system at the first time.

The "solution" presented is no solution at all: it just makes the error message to come forth. Booting goes on as expected - despite the message.

Different posts say that a clean install - something I had considered as a possible solution - won't have any effect on the bug.

Will make further investigation. Thanks for your help.

1 Like

Not many clues other than your suggestion.
I suppose it involves entering bios and changing the settings, which is something I have done in Windows but never in Linux. I do not even know how to - and I suppose it is very, very risky...
I tried a clean install of Ubuntu Mate, which did not change anything. Then I thought perhaps the bug would go away if I installed a different OS. I am now running Linux Mint, the bug is still there, the computer boots and goes on working normally.
Thanks for your attention.

Problem solved - and now I am back to Ubuntu Mate.

From what I read, the Shim update is incompatible with old Apple machines.
Solution from AskUbuntu (

You have to replace shimx64.efi with grubx64.efi

sudo su -
cd /boot/efi/EFI/ubuntu
cp grubx64.efi shimx64.efi


How does this solution hold up at future upgrades, do we take note now and make sure we do this again at next lts upgrade or is this a permanent solution?

Edit: forgot to say thank you for the solution :wink:

Thanks for the solution. But I can't find the files. I booted into a live usb and mounted my hard drive. But the boot/efi folder is empty. So there is no EFI and no ubuntu folder. I really appreciate your help.