Bootloader Gone - Ubu-Mate 20.04

Tweaking Into Space
My PC was running Mate 20.04 on a 5-partition 128GB NVMe SSD with 12GB RAM, an internal 5TB HDD for video data, and a USB3 5TB external HDD for backup. To remove a nagging unmounted "sdb" in the Nemo sidebar, I used the Disks app to tweak the auto-mount settings for the phantom "sdb" HDD partition.

When I tried to reboot, a message flashed something about no bootloader and it tried to boot from one of the HDD options. Neither of those work, so I booted from an Ubu-Mate 20.04 USB3 installer. I've unplugged both of the HDDs and am trying to get the SSD to boot without messing up its home partition.

Because the PC had brief freezes lately that even disabled keyboard input, my guess is that somehow the HDD had become the bootloader and it was too slow or going to sleep. My fond hope now is that getting the SSD bootloader working will fix the freeze issue, relieve my nagging fear of background ransomware encryption, and permanently remove that "sdb" sidebar icon.

Nothing I've tried has managed to fix the bootloader, but it's been an entertaining day (including notification of a missing "/cow"). Most recently I've been reading Repair Grub 2 from a live DVD but it's 4 years old and doesn't mention SSDs. The fdisk command shows the SSD as /dev/nvme0n1. At the bottom is a columnar Device list (not mentioned in the tutorial). I tried grub-install on every partition except Swap and Home, but it gives the "Embedding is not possible..." error and still no boot.

Gparted now shows the partitions as:
nvme0n1p1 as 21M of 487M with "boot,esp" flags
nvme0n1p2 as 238M of 500M that I'd labeled"Boot"
nvme0n1p3 as 0B of 2GB Swap
nvme0n1p4 as 20GB of 24GB labeled "/"
nvme0n1p4 as 54GB of 92GB labeled "home"

Is the bootloader supposed to go in the 487MB ...n1p1 EFI DOS format partition? It won't with the grub-install command, that just says no embedding and quits.

I'm guessing that unlike me, most people are on holiday. So in the hope of fixing it by reference to the Repair Grub 2 from a live DVD thread, I typed this in:

sudo mount dev/nvme0n1
sudo grub-install --boot-directory=/mnt/boot /dev/nvme0n1p2

That 500M partition now has an empty EFI directory and a grub directory with 3 subdirs & 4 files. I got the "will not proceed with blocklists" error. Then I tried the same install command with the 24G ...p4 partition that now has an empty boot partition and was again treated to the blocklists error.

I'm going to read the GRUB2 & EFI recovery - Tutorial to see if I should be using EFI instead of grub.

If anyone has joined me in avoiding the holiday mania, your help and ideas will be most welcome. :slightly_smiling_face:

1 Like

I gave up and reinstalled using Wolfman's excellent guide: Install Ubuntu-MATE using the “Something else” method and was glad to already have a separate /home partition! Even with installing some missing apps, it took a bit less than 2 hours (a fraction of what I wasted trying to fix it). Seems quite a bit snappier now too. Still probably some things to smooth out, but worth it if only for now having just EFI, ubu-Mate and home partitions. Maybe next time there's some niggling thing to fix, it will be easier. Anyway, hope this thread might be a tiny help to someone else with similar problems.