Bootloader issue - Ubuntu MATE takes over my PC

Hi all, I'm new to Ubuntu MATE but not Linux; I've been using it as my primary OS for a bit over 4 years now. I'm having an interesting issue with UM that I've never had before.

My PC is set up with 3 operating systems on separate SSDs: Windows 10, openSUSE Tumbleweed, and recently installed Ubuntu MATE. While all the data and whatnot is on separate disks, the bootloaders all seem to be on the same SSD, the one where openSUSE is installed. Not sure how that happened, but in the process of several distro hopping adventures and having to reinstall Windows, that's what I've got. It's worked fine so far - I set openSUSE as the first boot option in BIOS, and select my OS each time I reboot via grub.

However, installing Ubuntu MATE has screwed with my setup somehow. Every time I boot into UM, it seems to hijack my boot settings, and upon the next reboot my PC boots straight to UM instead of giving me the option. Not only that, the other bootloaders disappear from my BIOS settings completely. The only way I'm able to get it back is hit F11 and manually select a different SSD (which oddly doesn't even have an OS on it, I just use it for storage), and then when it tells me there was no OS found, I reboot and magically have my bootloaders selectable again from BIOS and the F11 menu.

I've had the full spectrum of Linux distros on the drive that UM is on now, including standard Ubuntu and Ubuntu Budgie, various other Ubuntu and Arch distros, Fedora, etc. I've had openSUSE installed for a little over 2 years, and my Windows install was probably done around the same time as openSUSE.

Any help with this would be greatly appreciated - it's quite the hassle to reboot multiple times when I want to switch from UM to something else, and more importantly I'm afraid that sooner or later something will get corrupted if I keep doing this process. Let me know what kind of information I can provide for troubleshooting.


Welcome @sm-wilson to the community!

Hi, @sm-wilson (Stephen Wilson) :slight_smile:

(Usual disclaimer: please note that I'm just another Forum user here. I'm NOT a Ubuntu developer or Ubuntu MATE developer)

I usually do the following changes in the GNU GRUB (GRand Unified Boot Loader) configuration in my Ubuntu MATE installations, that may also help you. Please, edit the /etc/default/grub file with administrator privileges, by running the following command (that will open the "Pluma" text editor as superuser):

sudo pluma /etc/default/grub

In that /etc/default/grub file, change the following lines (in your case, these lines may appear in a different order from what I show here and you will probably find other lines in between, which you don't need to change):


... change those lines so they become the following ones (in the case of the last line regarding GRUB_DISABLE_OS_PROBER=false , the difference is that we're "uncommenting" that line - by removing the initial # character - in order to activate the OS Prober in GRUB. The "os-prober" - - is an "utility to detect other OSes on a set of drives"):


After doing that, please save and close the file, and then run the following command:

sudo update-grub

Please, copy the output of the execution of that sudo update-grub command to some text file, so you can also include that output in another reply from you in this same discussion topic.

Now, please reboot the computer and reply later, in this same discussion topic, to tell us if this solved the issue for you. I hope this helps :slight_smile:

1 Like


I second @ricmarques advice to enable OS probing in UM grub configuration.

Next to it, you might want to have a look at

A possible catch is that each extra Linux installation adds (if not replaces) something in (the only) EFI partition. Sorry for vague answer! That is just an idea.

Good luck!


Hello, appreciate the reply! Unfortunately, enabling OS Prober was one of the first things I tried doing when I realized what was happening, before I found out that selecting my storage SSD seems to "reset" things. So OS Prober has been active since shortly after I installed Ubuntu MATE a few days ago.

I just discovered another issue that was also concerning - I booted into openSUSE and tried launching a virtual machine (using VirtualBox, that part isn't important), only to find that the virtualization on my CPU had been disabled. No idea how that happened other than some settings must have gotten reset to defaults by this whole fiasco.

I don't know if these issues are common across all variants of Ubuntu 24.04 or just the MATE flavor, but it makes me hesitant to keep using it. As mentioned in my first post, I ran the standard GNOME version of 22.04 for awhile and didn't have any issues like this. Prior to installing UM I had the most recent version of Linux Mint on this drive, again with none of these issues.

Hi again, @sm-wilson.

You're welcome :slight_smile: Unfortunately, my personal use cases of dual-boot ("dualboot") / multi-boot ("multiboot") are only for a Windows 10 + Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") dual boot scenario and for a Windows 11 + Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") dual boot scenario. I've never tried to set up a true multi-boot scenario as is the case of your setup (where you have a "triple-boot" / "tripleboot" scenario of openSUSE Tumbleweed + Ubuntu MATE 24.04 LTS ("Noble Numbat") + Windows).

Naturally, I suggest that you first make sure that you have good backups of your files before changing BIOS / UEFI settings and/or Boot Loader configurations, in case that your system becomes unbootable by any change (I imagine that you're already taking your precautions about that).

As you've mentioned that your BIOS / UEFI settings got apparently reset (that is strange!), I guess you may want to try to check if "Fast Boot" got enabled in your BIOS / UEFI settings and disable it, if you find that it got turned on, to see if that helps.

Other than that, my only guess (but it's only a guess!) is that the GRUB setups of openSUSE Tumbleweed and Ubuntu MATE 24.04 may be in conflict with each other, but I may be completely wrong about that.

You may want to try to use something like the "rEFInd Boot Manager" - - to see if it helps in your case, but I don't have experience with "rEFInd" to be able to help you more with that. Maybe someone else here in the Ubuntu MATE Community can help you more? I know that, for instance, @watchpocket uses "rEFInd" (see, for instance, the following topic: "In rEFInd, need 2 different OS icons for 2 instances of same OS" - )

1 Like

Good suggestions! I'll check fast boot in my BIOS, although would it show the grub menu at all if that were enabled? This is definitely one of the strangest issues I've had in all the years I've used computers.

To be honest, having 3 operating systems installed is more for fun than anything else. openSUSE is my daily driver, Windows 10 is there mostly for games and for when LibreOffice doesn't cut it over Excel, and the third one kind of floats around when I want to try something new (or new to me in this case, as I hadn't spent much time using MATE before).

I have heard of rEFInd before and have thought about trying it, but since my setup was working for me up until recently I hadn't bothered.

1 Like