BORKED CAJA: Desktop icons blinking on/off

This is totally a new one for me:
Caja has been crashing like crazy on me (see " Caja 1.26.0 – frequent crashing on UbuntuMATE 22.04" below) and I can't keep any folder with a PDF or JPG in it open long enough to even copy or move the file.

So I used the command-line to move a PDF out of its folder and onto the desktop, when all of a sudden all four of my desktop icons began to blink on and off, on and off, as if trying to say, "Danger! Danger!" or "Help Me!"

What this actually indicates, I have no idea, having never seen such a thing before.

I'm really hoping someone might know what this means & what to do about it, because I'm at near-standstill and can't get anything done with Caja acting so broken.

All ideas welcome, no matter how strange or off-the-wall they may seem. Thanks.

Just a curious question. Are you using the Pavel PPA as indicated in an earlier post and if so is there a compelling reason (AKA something not working correctly such as monitor or something else) versus running with the stock version?

They seem to have version numbers 1 higher with the exception of Marco which is 2 numbers higher of packages on my UM22.04.2. My Marco is set to Xpresent

1 Like

I was using the version in the repository, had the same problem & thought if I upgraded to the newer PPA version, that this would help, but it didn't.


Mine is not as bad and I tend to keep a lot of Caja viewer windows open on multiple virtual desktops but mine will often lock-up and crash if I hit the "back arrow" icon, especially if viewing files on a network share. All windows lock up. On 16.04 it was rock solid, on 20.04 I don't generally have so many views open.


Three things I've tried so far:

  1. I disabled ALL Caja extensions and re-booted. Didn't help.

  2. I did a complete removal of Caja, re-booted, re-installed Caja and (one-by-one) its accompanying apps and libs. didn't help.

  3. I made sure permissions on all files and folders were correct.

The problem is that all I have to do is open a folder that contains a PDF, a JPG or a PNG file, and that folder disappears.

I don't even get time to try to open the PDF or JPG.

Still trying to track down the source of the problem.

Also -- I only tried this once & I'm not inclined to try again -- when I opened a PDF from the command-line, the icons on my desktop started to blink on and off.

Hi, @watchpocket :slight_smile:

Is your Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") installation a fresh install or an upgrade from an earlier Ubuntu MATE version? If it is an upgrade, from what Ubuntu MATE version did you do the upgrade to 22.04? I'm asking because I've found the following question in the "Ask Ubuntu" web site, posted on 9th August 2022, where someone with the nickname "raddevus" (User raddevus - Ask Ubuntu) tried to upgrade from Ubuntu 21.04 directly to Ubuntu 22.04 (that direct upgrade path from 21.04 to 22.04 without upgrading first to 21.10 is not supported, although the user says that it was "Software Updater" that offered that direct upgrade path) and that user got the same problem of desktop icons flashing / blinking:

Video from that user illustrating the issue (available at

1 Like

Wow, interesting. Thanks for that, ricmarques.

My Jammy install, however, was a clean install on an empty NVMe drive.

(I've never done a system upgrade, the idea scares me. I've always done clean installs. Things can be bad enough even with a clean install.)

Icons blinking is definitely a freaky phenomenon, and it may signal something specific. Meanwhile I'm still on the trail. Thanks again.


I wonder if the following has anything to do with this problem:

I have an nvidia driver with an odd version number, as well as one with a version matching my kernel:

--> dkms status 
nvidia/535.54.03, 5.19.0-1010-nvidia, x86_64: installed
nvidia/535.54.03, 5.19.0-45-generic, x86_64: installed

I've never seen one with a number like "1010" as part of the kernel version.

Do I need both of these?
Should I remove everything with "1010" in it (see below)?

When I issue this command:

dpkg -l linux-image-* linux-headers-* linux-modules-* linux-objects-* linux-signatures-*'

I see this (and only hope these are the needed & correct kernel items):

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                    Version               Architecture Description
un  linux-headers-3.0                       <none>                <none>       (no description available)
ii  linux-headers-5.19.0-1010-nvidia        5.19.0-1010.10        amd64        Linux kernel headers for version 5.19.0 on 64 bit x86 SMP
ii  linux-headers-5.19.0-45-generic         5.19.0-45.46~22.04.1  amd64        Linux kernel headers for version 5.19.0 on 64 bit x86 SMP
un  linux-headers-686-pae                   <none>                <none>       (no description available)
un  linux-headers-amd64                     <none>                <none>       (no description available)
un  linux-headers-generic                   <none>                <none>       (no description available)
ii  linux-headers-generic-hwe-22.04 amd64        Generic Linux kernel headers
ii  linux-headers-nvidia-5.19             amd64        Nvidia-5.19 Linux kernel headers
ii  linux-image-5.19.0-1010-nvidia          5.19.0-1010.10        amd64        Signed kernel image nvidia
ii  linux-image-5.19.0-45-generic           5.19.0-45.46~22.04.1  amd64        Signed kernel image generic
ii  linux-image-generic-hwe-22.04  amd64        Generic Linux kernel image
ii  linux-image-nvidia-5.19               amd64        Nvidia-5.19 Linux kernel image
un  linux-image-unsigned-5.19.0-1010-nvidia <none>                <none>       (no description available)
un  linux-image-unsigned-5.19.0-45-generic  <none>                <none>       (no description available)
ii  linux-modules-5.19.0-1010-nvidia        5.19.0-1010.10        amd64        Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP
un  linux-modules-5.19.0-43-generic         <none>                <none>       (no description available)
ii  linux-modules-5.19.0-45-generic         5.19.0-45.46~22.04.1  amd64        Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.19.0-1010-nvidia  5.19.0-1010.10        amd64        Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.19.0-43-generic   5.19.0-43.44~22.04.1  amd64        Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.19.0-45-generic   5.19.0-45.46~22.04.1  amd64        Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP

My question, then, would be: Am I perhaps using the wrong nvidia driver which may be causing Caja to crash and causing anomalies like blinking icons?

(Also just noticed that "22.04.1" is indicated in the files above, when everything else (inxi, neofetch, hardinfo) tells me I'm on 22.04.2).

Update: I fixed the driver situation (got rid of "1010") but Caja still crashes.

My nvidia driver (535) does not appear to be the source of the crshing problem.

You said "all suggestions welcomed," so here goes, but I don't know if it will help.

PDF, jpeg, and png are all types of files that Caja can preview, both in the the File Manager itself as well as in thumbnails on the desktop. Could it be that there's a bug in that preview code? Could such a bug depend on the graphics driver?

You could try opening File Manager Preferences, clicking on the Previews tab, and setting everything to "Never." Close, reboot, and see what happens?


Hey thanks! I'm away this week (writing from phone now), will explore this asap & report back.

@DaveHighland I think you've hit the nail on the head.

I went into the File Manager, opened the "Preview" tab, and set everything there to "Never."

Then, one-by-one, I "un-Never'd".

The problem is with the "Other Previewable Files" -> "Show thumbnails" setting. If that is set to "Never", the problem goes away.

You may be correct that there could be a bug in the preview code. I tend to think it's not related to the graphics driver because I earlier changed to the Nouveau driver and had the same problem.

I wonder if anyone is able to reproduce the problem? It seems these Preview settings are set to "Always" by default, in which case I'd think others would have noticed the problem.

In any event, since I don't need thumbnail previews, I will now keep the "Show thumbnails" set to "Never."

Thank you very much for that suggestion, as I've been grappling with this issue for several weeks now. I'm marking this issue as solved.