Brightness Applet not working?

Screenshot at 2023-12-04 14-39-34

Hi, the keys that control brightness weren't working for me. I tried fn +, CTRL +, alt + etc and those didn't work. So I tried to adjust the brightness in the Power Management settings, but there's isn't a setting for it. So then I found that you could add a brightness applet to the top panel, but when I added it is has a red cross-out over it and it doesn't work.

Any idea what to do? I'm on a Framework 13.

Thank you

Have you seen this post? Cannot change screen brightness - Framework Laptop 13 - Framework Community


Do I have to reinstall the OS? I already have everything set up the way I want it.. :smiling_face_with_tear:

After a long convo with ChatGPT:

It appears that there are no backlight devices listed in the /sys/class/backlight/ directory on your system. This situation typically indicates one of the following scenarios:

  1. Graphics Driver Issue:
  • If the graphics drivers are not properly installed or are incompatible with your system, the backlight devices might not be correctly recognized. Ensure that your system has the correct drivers for your graphics hardware.
  1. Kernel Support:
  • The current Linux kernel you're running might not support the backlight control for your specific hardware. This could be the case with certain newer laptops or specific graphics hardware.
  1. ACPI Issues:
  • The issue could be related to ACPI (Advanced Configuration and Power Interface) settings in the BIOS or UEFI firmware. Sometimes, changing certain settings in the BIOS/UEFI can help recognize hardware like backlight controllers.

Given these possibilities, here are some steps you can take:

  1. Check and Update Graphics Drivers:
  • Ensure that you have the correct drivers for your graphics card installed. You can do this by checking the "Additional Drivers" section in the "Software & Updates" settings.
  1. Update Your Kernel:
  • If your hardware is relatively new, updating to a newer Linux kernel might provide better support. However, updating the kernel can be a complex task and might lead to system instability, so it should be done with caution.
  1. ACPI Settings:
  • Check your BIOS/UEFI settings for any options related to ACPI and backlight control. Be cautious when changing BIOS/UEFI settings, as incorrect configurations can affect system stability.
  1. Search for Specific Solutions:
  • Look for solutions specific to your laptop model or hardware. Sometimes, manufacturers or communities may offer specific advice or patches for certain hardware.
  1. Seek Community Help:
  • Consider posting detailed information about your issue on Ubuntu forums or Ask Ubuntu. Include your laptop model, Ubuntu version, and any relevant output from terminal commands. The community might have insights specific to your hardware.

Someone found me the solution. The kernel was out of date!


Hi, @Johnny_McIvor :slight_smile:

I'm glad that upgrading the Linux kernel of your "Framework Laptop 13 (13th Gen Intel® Core™)" - - solved your Brightness control issue. Thanks for having added that information :slight_smile: Having said that, I'm curious: you posted this topic in the "Raspberry Pi" subcategory of the "Support & Help Requests" category here in the "Ubuntu MATE Community" discussion forums. I'm assuming that was a mistake given that "Ubuntu MATE for Raspberry Pi" - - is for the Raspberry Pi which uses ARM processors - armhf (ARMv7 32-bit) and arm64 (ARMv8 64-bit) - while your "Framework Laptop 13" has an Intel CPU / processor instead. Am I right?

By the way: the only Ubuntu related guides that I can find, in the "Framework" web site are the following two guides:

... and those two guides are about regular "Ubuntu 22.04 LTS desktop" ("Jammy Jellyfish") and "Ubuntu 23.04 desktop" ("Lunar Lobster") installation in that laptop model. What Ubuntu version and flavor did you end up installing in your "Framework 13"?