Broken popup notifications

Popup notifications including the preview under notification settings stopped to show up. Any idea to bring them back to life?

The notification sound still appears. Also the notification applet works and displays the notification list.

Hi :slight_smile:

Do you have this package installed ?


Try to run this from a terminal to check if a notification appear :

notify-send test

You can also search in menu for "popup notifications" and insure this checkbox is checked :

Keep us updated :slight_smile:

The package seems to be installed, I can read the help options.
I entered notify-send test without any result or message.

The option "Use Active Monitor" is checked. If I click "Preview" no notification is shown.

Popup notifcations worked flawlessly for several months. They disappeared a few weeks ago.

Dumb question: In the Notification Settings, is "Do Not Disturb" set?

Good point @gordon ! xD

@jodother, Can you try playing with the Monitor option inside Popup Notifications configuration ? :


Are you using the default Marco composer ?

Do you have this alias inside your .bashrc file ?

└──╼ $cat ~/.bashrc | grep alert
# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

Thank you guys, problem solved:
"Enable do not disturb" was checked under System Settings > Notifications. I unchecked it, and the notifications are back.
My stupid fault :roll_eyes:
I thought that this option just allows for the "do not disturb" option to be appear in the applet settings (where it had been unchecked).
To avoid this misunderstanding, maybe it would be better to name this option "do not disturb" instead of "enable do not disturb" and to place it in a single setting dialog instead of two settings.