Brother printer drivers

Hl all, thanks for all the work that everybodt has put into producing such a great OS.
I can not get a brother HL-1110 printer to print in Ubuntu Mate 16.04. The printer works but puts out a blank page.
I have got it to work properly in Ubuntu 16.04 on another pc
I have downloaded all the driver packages I could find from the Brother Support centre and used the instructions as set out at https://sites.google.com/site/easylinuxtipsproject/15
Worked in Ubuntu but not in Mate.
When the terminal gets to the question about the Device URI, you answer N for a USB printer and Y for a network printer, I put in N but it keeps coming back with can’t find any thing on the network
On another Mate pc I get /home/graham/Downloads/linux-brprinter-installer-2.1.1-1(1): unknown suffix – ignored
[email protected]:~/Downloads$
I’m not very good at terminal work and if the given commands don’t work i’m stuffed
Any help would be appreciated
Thanks
Graham

Hallo Gege

You may have already tried this - if not it may help.

a)
Does your printer have a fixed IP-address?

b)
If not, do you know how to give it one?

c)
Have you tried setting up the printer using the fixed IP-address?

Please answer each question separately as this will help us to give you specific advice.

If you’ve tried that approach then I’m out of ideas. I use HP printers because they are usually a safe bet when using Linux systems. :slight_smile:

Hi alpinejohn, my answers are no to all questions but if i’m using a usb cable to connect the printer, i didn’t think it would have an IP-address
Thanks

Quite so Gege.

Connecting via usb could be a problem that you might not get around. Have you tried looking for drivers on the “asian” websites - they sometimes have different version that may work better.

If usb fails is a “network” connection a possibility for you?

(I won’t be back on the forum for at least 24 hours…)

There is no Wifi on this little cheapy
thanks for you input
Cheers

Solved Thanks to wolfman in another post.
He suggested using Synaptic and installing any thing related to Brother for some one else and BINGO my printer printed at last.
Good work wolfman
Many thanks
Gege

1 Like

Hey I’m glad you could solve it, I have this printer too and unfortunately I’ve had problems at different times depending on the kernel version. Another alternative I use when nothing else works is printing through a Windows VM, works just fine. Regards.

Asta 1986

Thanks for the info, I’ll take note of things changing with kernal
changes, good thing to know.

Hate having to use that other os even as a vm.

Cheers

Gege