Bug(?): Cannot untick "don't ask for password "

This might be correlated with my other problem about "unable to mount drive". i cannot untick the "don't ask for password on login" option in the change user password menu. no matter how hard I clicked, it just doesn't budge.
i tried to edit the lightdm file but it does not provide me the password box, just my username and login button, which is not as i expected for.

What it the output of id command for the tentram user?

sorry, took awhile to reply.

here's my id output:
uid=1000(tentram) gid=1000(tentram) groups=1000(tentram),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),116(nopasswdlogin),118(lpadmin),120(scanner),128(sambashare),129(chrome-remote-desktop)

any idea? what should i do now?

oh crap..... i did some mistakes. i editted the sleeck greeter to lightdm-gtk-greeter which Im not very sure if it will replace the usual greeter with no password. now im stuck in logo forever. cant get into desktop. help

well, luckilly, puppy linux is nearby, glad that able to help on editting the corupt file.

i was able to solve the re-enable password on login by using terminal code.

sudo gpasswd -d username nopasswdlogin

after using this code, and reboot, the greeter has password. in the "user and group" menu shows "Ask password on login", but still, not tickable. I think the Users Settings menu has a serious problem, which i will list what is not working other than "don't ask for password".

Things that are not working in "Users Settings":

  1. [Add] Button
  2. [Delete] Button
  3. [Change] on Account type
  4. [Advanced Settings]
  5. "Don't ask for password on login" tick on [Change] Password

I think MATE has this problem for a very long time already, idk, im just guessing.

i already switched to Zorin, so this post will remain unsolved for idk how long.