Built-in Audio keeps getting disabled

There was no option in Sound Preferences to enable Built-in Audio:
Screenshot at 2021-02-01 00-29-31
Profiles only has the option of off.
So I read this suggestion and installed pavucontrol and got my headphones to work. Only problem is any time I take out my headphones to use the speaker I cannot enable the Built-in Audio. Is there anyway to keep my Built-in Audio from getting disabled? Thanks in advance for any advice.

Hi and welcome to the Ubuntu MATE Community,

We're going to need a few more details to help you.

  • What release of Ubuntu MATE are you using ?
  • What is your computer model ?
  • Does the speaker work when using another operating system or trying a live session of a distro ?
  • Is your onboard audio activated in your computer BIOS/UEFI ? (I guess so since you got sound out of your headphones but who knows ?)
  • When your headphones are plugged in and the sound is working, can't you choose your speaker as an output in the output tab from the sound preferences ?

Hello and thank you very much for the reply.

  • Using Release 20.04.2 LTS (Focal Fossa) 64-bit, Release 20.04.2 LTS (Focal Fossa) 64-bit, MATE 1.24.0
  • To clarify, both my headphones and hdmi sound both work in Ubuntu Mate.
  • Onboard HD Audio controller is [Enabled] in BIOS.
  • In order to have headphones as an optional device in Sound Preferences/Hardware they need to be plugged in when I Log in. If I keep the Sound Preferences window up I can change between HDMI, and Headphones even if I disconnect my headphones. If I disconnect my headphones when the Sound Preferences window is not up, I default to HDMI but no longer have the option: Profile: Analog Stereo Output (Headphones)

Ok, thanks a lot for the information.
You may want to try the Sound Switcher Indicator to see if you can change the output that way.

1 Like