Ć instead of ç on 20.04

Before I updated to 20.04 I seem to remember that typing '+c (accentuation plus the letter c) resultet in the letter ć. Now, however, I get the letter ç. I have been looking for explanations online, but I am not able to find any good reason for the change. Does anyone know how to get the ć back?

Kind Regards
Nicolai

Hi Nicolaigideon,
Did you select the correct language for your keyboard and IBus like a entry method?

2 Likes

Hi Nicolai
Was wondering the same as I remembered the behavior you mentioned from way back, and for me the following did the trick:
Menu->Keyboard->Layout tab

As I type mostly English I set the top layout to "US International with dead keys" and added Dutch as second layout.
Dead keys make that you can just type ' + c to get ć and " + e to get ë as I understand it.
Also under options I set right ALT for compose key.
And "switching layouts" to CONTROL+WINKEY
Now ' + c results in ć for me, and right alt key + , + c results in ç
And CONTROL+WINKEY toggles between Dutch layout and US Int.

But like Tim said; check your keyboard layout.

1 Like

My language setting is Danish. I have setup a fast-switch key combination for getting to Serbian (latin) keyboard layout. That gives me quicker access, but it would still be immensely much easier to just being able to use the method that has been altered...

I have tried to dig into the whole dead-key thing, but I think I'm not savvy enough to make it work. However, I did manage to setup a shortcut for changing layouts, so now I can change to Serbian (latin) fairly quickly. It's better, but it would be even better if " '+c " could be used... Perhaps I'll manage to make it work at some point :slight_smile:

Hi Nicolai,
Are you actually running Ibus? Are you using a minimal install of Mate or the full install?
Could you please check menu->language support, if you get a prompt about installing additional packages you can do so.
After that check your keyboard input method system:
image

YESSSS! That solved tbe problem!!! (That, and a reboot) Thank you SO much!!!

Ah great :slight_smile:
As stated; remembered the same thing from way back.
Had it sorta working with deadkeys and GTK_IM_MODULE=xim in /etc/environment.
Discovered that otherwise it would only work in some applications like Firefox, or so it seemed.
xim is old though and has other drawbacks from what I've read.
Did minimal install myself so no IBus whatsoever on my PC.

So:
sudo apt-get install ibus
Added ibus-daemon to startup applications through menu
added the following lines to /etc/environment below path line:
sudo nano /etc/environment
GTK_IM_MODULE=ibus
QT_IM_MODULE=ibus
[email protected]=ibus
(as stated by ibus-setup output)
And got it working too :yum:

You probably had IBus already running than, but other input method? Or none?
Anyway; glad to help out, enjoy the ć's and ç's!

I got IBus, so I just needed to turn that on in my language-support. It seems to work throughout the entire system, so no further action has been needed taken, and that is very pleasing!!!