CAD engineer switching from W7 to ubuntu MATE


#1

Hello,

short story long: civil engineer with a plan to switch from Windows 7 to linux.
I would like to write my progress here, not only for me to remember what to avoid in next install but also maybe it will be handy for someone else. I am SORRY in advance for describing stuff in lame terms. If I should rather post it somewhere else write me so, but maybe it could be interesting to see how noob struggles.
Reasons for this change is one third paranoia, one third tax evasion, one third tired of windows.
Hhints are appreciated.

Current situation:

Hardware

  • office - AMD FX8320E/ 8GB RAM / GTX 1060 6GB / 128 GB SSD W7 / 240 GB SSD for linux / 640 GB data
  • home - dell latitude E6330 / i3330M/ 8GB RAM
    So far I used windows/dos for 20 years

Software and what I want to work on linux

  • I mainly word in 2d (dgn,dwg) with output in pdf, I print drawings in office and outside if plotting bigger formats, I sometimes do visualizations (rhino, blender,gimp for post production) and I use openoffice, mozilla and thunderbird fro normal office things. For syncing I use dropbox. I am in office with network printer and with few collegues we use synology NAS for sharing stuff. Sometimes I use splashtop sofware for remote access. I was not able to make work wake on lan so far. I use office printer/scanner

Current progress with notes (11.2.2019)

  • ubuntu 18.04 MATE installed, minor bugs when switching panel layouts (NOTE: dont mess with it anymore, lost "start" menu when picked "familiar" / Mutiny is nice but redmond has smaller icons - more space for drawing
  • when installing all was automated, custom disk/partition too complex (swp/home/) maybe next time will try to play with that
  • net - mozilla ok ... need to trransfer setting from win
  • sharing - dropbox installed woth some error pop ups (drive ext4, noticed some discussion about crypting, but it works, maybe will change it in future for "syncthing" - have to find out about compatibility for collegues who work in win10) ... todo
  • thunderbird - not synced yet, IMAP 30 gb, ... todo
  • commander - installed krusader (sudo apt install krusader)
    (had to add something like txt reader i suppose ... sudo apt install kate)
  • blender - installed and running - todo: test new cycles
  • 2d CAD - chose 3ds draftsight - didnt find in software boutique, downloaded package, tried to install through some gdebi installer ... so far didnt work ... :((((( ... solved via opening gdebi as admin (sudo gdebi-gtk and opening previsly downloaded deb file)
  • win network - didnt work so far - can connect directly to machines if i know IP, they only doesnt show up, minor thing
  • network printer/scanner - found instruction to install samba (sudo apt samba) ... konica bizhub 195/215 havent found linux driver so far - tried several variants generic drivers didnt work ; tried to upload files to print through browser but printer freezed and device is no longer suported for firmware update
  • freeCAD - some bug on start (error webGUI , starts blank) ... to do (try reinstall, follow brianrh link )

NOTES TO PROGRAMS
Draftsight

  • feels a little sluggish but at first look same as AutoCAD cca 2008 (before ribbon)
  • have to now setup layout (dimensions, styles, lines, menu ... ) will try compatibility with made lines rsc/lin (free version does not support dgn underlay, will buy pro version)

KRUSADER

  • must add rar archiver, zips are ok

#2

When you used Gdebi, did Gdebi ask for your user password either when you opened Gdebi or when you tried to install the 3ds draftsight deb whilst in Gdebi?


#3

thats the thing, didnt ask for password, only at first asked for accept license agreement at first but than nothing .. i tried to run it again 2nd time but nothing happened.... i do not know how to kill process in linux or see how proces run in real time :confused: ... didnt try after reboot yet .. EDIT: at win7 i managed to install it so i did try it at win


#4

Okay, I think the issue with Gdebi is the fact that GKSU (the GUI password manager for applications that need password access) has been removed but the alternatives are still being implemented. You'd have thought the main Debian/Ubuntu devs would not have removed one function before they had the replacement fully in place.... But, hey ho....

Anyway, the way to ensure you have full admin rights on Gdebi so that your deb installs properly is to open Gdebi from a terminal with the "sudo" prefix command. See below:

sudo gdebi-gtk

So, open a terminal and copy/paste the above command into it and press "Enter". It will ask for your password in the terminal. Once you have entered it, Gdebi should open in "admin" mode (otherwise known as "superuser" mode in linux).

Then, from inside Gdebi, open the deb file in question and install it. Then report back on here to confirm whether it has installed or not.


#5

I've used a free 2D Draftsight in the past as an alternative to Autocad and had always been able to find an Ubuntu version to install. It looks as thought you can possibly get DraftSight 2018 SP3 free Beta for Ubuntu if that will serve your purposes, from here:

https://www.3ds.com/products-services/draftsight-cad-software/latest-version/

I think it is saying you can pay for extra tools and presumably it will be a RC rather than the beta version.

Also if you are interested in 3DCAD there is open source software, which again I haven't used for a while, called FreeCAD but used to be surprisingly good and well supported.

Now if anyone associated with Ubuntu Mate could create a snap for these.......


#6

Hi, thank you very much, with that gdebi opened way you suggested it works and I installed it without problem.

I will look more into commands asap, seems its a basic must in linux :slight_smile:


#7

So draftsight works now. I want to test it first to see if I would be productive in it, but payed version is not so expensive so I will probably go for it.

Thanks for hint with FreeCAD, looks interesting but so far it didnt work. Will try under windows ... It would be handy to have something more precise than Blender


#8

Out of interest I tried to install FreeCAD again but I got a " No module named WebGui" error so I uninstalled then followed the first few lines of the instructions below and FreeCAD now works on my Ubuntu Mate 18.04:

https://techoverflow.net/2018/06/03/how-to-fix-freecad-no-module-named-webgui-on-ubuntu-18-04/.

Regards.


#9

Maybe consider LibreCad

https://librecad.org/

It should be in the Ubuntu repos


#10

Hallo
If you are having trouble with the scanner consider the VueScan program. It is not FLOSS, but covers around five thousand different scanners:


Hope it helps. :slightly_smiling_face:


#11

LibreCad was in package already installed, looks bit nicer than OpenOffice
Honestly I need only: writer - styles and numbered list ; calc - basic arithmetic
I had problem with newer MS Office, it has so frustrating UI