Caffeine-indicator not showing on the panel

I am moved my MacBook Pro from using Ubuntu-GNOME to Ubuntu-MATE and it has been awesome! I do have an issue that I am looking for help in. I use caffeine to stop screen-saver from starting when I watch movies. I installed and launched but I do not see the icon on my panel. I know it is run from what see below,

[email protected]tu-MATE-MacBookPro:~$ ps aux |grep caffeine rican-l+ 13144 0.0 0.5 381700 42960 ? Sl 10:44 0:00 /usr/bin/python3 /usr/bin/caffeine rican-l+ 15099 0.0 0.0 15184 2316 pts/1 S+ 13:36 0:00 grep --color=auto caffeine [email protected]:~$

Any ideas as to why

do you have indicators installed and enabled?

see this page if not

I use this ppa and it works fine under Ubuntu Mate 14.4.2

i recommend xscreensaver,

Sudo apt-get update

sudo apt-get install xscreensaver

then add to list in the start up, then reboot, then you can open xscreensaver, and click to disable the screensaver, and close it.

that’s all.

you’re welcome.

I’ve had the same problem after switching from Ubuntu 14.04 LTS to Ubuntu Mate 16.04 LTS. Trust me, I looked everywhere online and the closest solution was to install Caffeine Plus. It didn’t work quite like I like so I took another approach and found a way to run the Caffeine-Indicator that I was used to.

What you want to do is go to file system/usr/bin and you fan find a file of caffeine-indicator there. Then copy it to your desktop for easier access. You want to right click and go to properties, go to permissions, and click the check box to execute as program. This way you can just double click it and the indicator pops up on your panel. It’s basically the same way to run the Linux version of Minecraft.