Caja Rename Behavior Changed


#1

My work is audio transcription. My normal production involves making copies of template files, and then renaming them to match the name of an audio file I’m transcribing. The normal procedure is to right-click on the audio file in Caja, click on Rename, and then copy the name to the clipboard. The way this always used to work before yesterday afternoon is that the filename, not including the extension, is highlighted. I copy that, then apply the rename procedure to the .doc and .xls files, pasteing in the name of the audio file.

Yesterday afternoon something changed. When I right-click on a file in Caja, and click on Rename, the entire filename plus extension is highlighted. There appears to be no way to un-highlight the extension. This makes it impossible to use copy and paste to rename a file. Oddly, the behavior is different on the desktop. There I can rename the way I used to be able to in Caja.

So, I have a work around, but it’s annoying.

I thought about using rename, and copying the file name to a text file, editing it there and renaming the other two files as appropriate. When I pasted the filename, I got the entire pathname, starting with /home.

During this time I’ve logged out and back in, and ran some upgrades that required a restart. Neither logging out nor restarting changed the behavior of Caja.

Very weird.

This morning Caja rename is back to normal.

Any ideas on what happened and how to fix it if it happens again?

Ubuntu MATE 18.04


#2

Hi @Moonguide, I use rename a lot so if this happened I’d instantly notice. I hope it is a one-time fluke in your case. I will note I use F2 and List View exclusively and never menus.

Best I can tell, Caja’s initial select simply looks for a period and not tied to file type or anything deeper. But if you do see it again, take note if it may be only certain file types/extensions. And if it is system wide or confined somehow. It may be interesting to note if menus vs. F2 was different, too.


#3

Well, you learn something new every day. I was not aware of F2, and I never tried the Edit menu in Caja. As things are back to normal right now, I don’t see any difference in their behaviors. I did try the rename procedure on other files in other directories the day before yesterday, all with the same result, so it doesn’t look like it’s restricted to certain file types or confined to a specific directory. I didn’t do an exhaustive try with this, but I did try more than a couple directories.

I"m guessing and hoping this was a one time fluke.


#4

Glad you learned F2. And by the way, hit F2 twice to select the entire name. Let us know if it happens again.