Calibre installation script fails to run (command 'wget' not working) - workaround

Cannot install latest version of e-book management software "Calibre" via the installation script from the Calibre website.


Temporarily disable IPv6 addressing.

To temporarily disable IPv6 address on Ubuntu-Mate 22.04 Jammy Jellyfish execute the following commands:

$ sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
(terminal output =): net.ipv6.conf.all.disable_ipv6 = 1


$ sudo sysctl -w net.ipv6.conf.default.disable_ipv6=1
(terminal output =): net.ipv6.conf.default.disable_ipv6 = 1

The above commands will temporarily disable IPv6, meaning that the settings will not persist after reboot. To re-enable IPv6 reboot your system or execute the above commands again however reverse the logic and change 1 to 0.

So I used:

$ sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
$ sudo sysctl -w net.ipv6.conf.default.disable_ipv6=1
  • Then I ran the Calibre installation script. It worked as expected and installed the latest version of Calibre.
  • Then I rebooted the computer via the terminal.

Once re-booted I was once again unable to ping, i.e. IPv6 addressing was working again. I left the computer like this, i.e. I made no permanent change to IPv6 addressing.

I will use this workaround for "wget" commands until the systemd bug is fixed.

source: [] :slightly_smiling_face: