Camera not working

Hi all, I recently started using a Linux PC and after trying out quite a few Distros, I landed on Ubuntu MATE as the final one. One of the main reason was everything just worked right after the install, well everything except for one thing which is really no biggie if it ever does but I’d like to give it a try. I am very new to Ubuntu MATE so please bear with me. I have an older MSi Wind U100 Plus netbook that I still love to use. In fact it looks the same today as it did brand spanking new. Sure it’s old technology to some, but I love it. The thing that does not work with Ubuntu MATE is the camera. It worled fine under windows, so I know it is a driver issue. Any suggestions and if there is a driver where and how do I install it? Thanks!!!

Hello
Is your camera detected at all?
If not, have you checked your BIOS settings? (Sometimes you can kill hardware from the BIOS)
Have you gone through the “Drivers” step in Welcome -> Getting Started ?
Cheers

It cannot find the camera and yes on the set-up settings.

I haven’t checked the bios setting, so I’ll give that a try later this evening.

Hi @Dillinger63,

do you have Skype installed and have you checked the Video settings there?:

Do you see the cam in the output of lsusb (in a terminal)?

Also, can you give the output of dmesg after a fresh boot?

No Skype installed as I don’t use it and to the other poster that asked if I checked the camera in the set-up settings when you first boot the computer, there aren’t any options for the camera.

As asked for; open a terminal and enter:

lsusb

another way

inxi -b
1 Like

I just saw your reply on this so I’ll try it. Thanks!

1 Like

I typed that in and I receove the message No command ‘1usb’ found did you mean Command
1usb from package usbutils (main)

You misread his command suggestion. I’ll type this in capitals, you enter the command in lower case letters.

LSUSB

You should enter lsusb

You can directly copy the code line above and enter it into a terminal.

1 Like

I did enter it in lower case. I remember back in the old DOS days you would do a CD to Change Directory. Am I in the wrong directory and if so what directory do I need to be in and in Linux, how do I change it?

Sorry, please try again. You do not have to be in a specific directory for this command to work. Open your terminal and type in the letters “lsusb” and then press Enter. You should get a listing of devices. Good luck Dillinger63.

@mdooley was right about you mistyping the command.
The command output you provided shows you typed:

1usb

instead of

lsusb

I typed lsusu and the message was alot of bus 001 device linux foundation 2.0 root hub

bus 005 device 002 Microstar international bluetooth device EDR device, and then some more

Bus 005, oo4 and so on but with nothing behind those numbers.

Hi @Dillinger63,

have you done a full system update?, it may simply be a case of missing dependencies?:

Could you please give the full output of lsusb? Don’t try to interpret it, give us the whole stuff. And also the output of lspci as I believe your camera is integrated (i.e. not an external USB one).

Also, can you give the output of dmesg after a fresh boot (so that it won’t be too long and unreadable)?

I will try. Since I’m new to Ubuntu it may take me a while.