Can not install ttf-mscorefonts-installer

I would like more fonts for LibreOffice. Tried Software Boutique and Ubuntu Software Center, no joy.

Found this site using Google —

After doing a software update I ran this command — sudo apt-get install ttf-mscorefonts-installer

Which resulted in this screen and I can’t get past it.

┌─────────────────┤ Configuring ttf-mscorefonts-installer ├─────────────────┐
│ │
│ TrueType core fonts for the Web EULA


│ IMPORTANT-READ CAREFULLY: This Microsoft End-User License Agreement
│ (“EULA”) is a legal agreement between you (either an individual or a
│ single entity) and Microsoft Corporation for the Microsoft software
│ accompanying this EULA, which includes computer software and may include
│ associated media, printed materials, and “on-line” or electronic
│ documentation (“SOFTWARE PRODUCT” or “SOFTWARE”). By exercising your
│ rights to make and use copies of the SOFTWARE PRODUCT, you agree to be
│ bound by the terms of this EULA. If you do not agree to the terms of
│ this EULA, you may not use the SOFTWARE PRODUCT.

│ │
Ther is an OK where the cursor is showing…
I tried return, tried highlighting the OK and return tried double click, all to no avail.
How do I proceed?

Thanks, Fred

Hi Fred.

In a terminal, the way to select a particular option button is by pressing the tab key. This will cause the highlighted button to change from one option to another. So, use the tab key to choose the correct option, then press the enter key.


Thanks, @stevecook172001
Been sooo long since I used terminal mode totally forgot that.

But when I tried again this morning I received the following message

fred@Lenovo-G780:~$ sudo apt-get install ttf-mscorefonts-installer
[sudo] password for fred:
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Now what do I do?

Also will this install them in my usr space so if I have to do a recovery I won’t need to go through the process?

Thanks, Fred

Cancel that request…

Did a reboot and tried again, it gave me a message about something being interrupted and do “sudo dpkg --configure -a”, so I did and it ran just fine and the fonts are installed.

When I bailed last night I probably caused the problem.

Thanks, Fred


You can also use the arrow keys to move the highlight and space to accept the selection. In fact, until now, I thought that was the only way you could do it :wink:

1 Like