Cannot change language to German despite all efforts

Okay, like the title says, I tried everything I know and then some to change my system language to German, this included:

Language settings tool in the Control Center > Add/Remove Languages > remove all other languages except German and set default language to German etc.

Manually editing the language file in: /File System/etc/default/locale.

Opening Synaptic and manually removing all English language packages I could find.

Ruuning the following terminal command:

locale -a

followed by:

sudo locale-gen de_DE.UTF-8

and then:

sudo update-locale LANG=de_DE.UTF-8

(Edit: Added "sudo" to the above command as that is most likely why I got the "Permission denied" message!).

which returned a permission denied message:

despite the fact that the German language packs were/are already installed!.

Using "localepurge" to remove all language packages except German.

Does anyone have any ideas or is this a bug? as I have never come across this problem with an Ubuntu based system in the past. It just won't change even though all references to English were removed?.

The odd thing is, I was in the middle of writing a language guide and doing things I have already done a 1000 times in the past!. Needless to say, I haven't finished the guide yet!. :smiley:

has your ~/.pam_environment settings overridden your other settings? I had a similar problem when trying to set my datetime settings the way I like them. I changed them everyone to no avail; nothing worked until I changed that file


thanks for your reply. :smiley:

I just noticed that the above command doesn’t (didn’t) have “sudo” in front of it, maybe that is why I got the “Permission denied” message?.

I also took a look here:

and will need some time to read through it, thanks for that!. :smiley:

1 Like

Okay, after new updates the problem is almost solved, I managed to change the language but this option didn't show which changes the folders to the current prefered language:

I will still mark this as solved though.

Thanks for your help. :smiley:

You’re welcome. Glad you’re almost there?


I also forgot to mention that at the time I was using UM15.04 Beta, which I have downgraded to UM14.10 on my test partitions. I also have UM14.04 LTS on my Laptop which I don’t want to mess around with.

I am done with the Beta for now and will wait until 15.04 is stable. :smiley:

I will still go ahead with the guide I was going to write in the next few days!. :smiley:

Thanks for your support. :smiley:

No worries mate, glad to have helped even in the small way that it was.


I actually haven’t bothered with this problem as I was doing other projects, I will try again in a few days when 15.04 goes stable. I am using 15.04 daily build from the 19th of April. :smiley: