Cannot change the background

I upgraded my 16.10 Beta install to 17.04 a couple of weeks ago without any issues :slight_smile:

Yesterday I notice that I can no longer change my background. Anyone else seeing this?

Hi @anon42388993,

I just did a fresh install and the problem is still there, I used the daily build from yesterday so it should be up-to-date!. :frowning:

1 Like

Problem is still there after doing several updates today and doing a restart!. :thumbsdown:

I have not been using my install lately. Think I’ll start using it again when alpha comes out. Perhaps we will see a fix or time to file a bug on it.

Hi @anon42388993,

I am currently downloading the daily build again and will do another complete install and see if that helps!. If not, I can eventually file a bug report. :smiley:

I have done a fresh install of Ubuntu-Mate 17.04 from nightly builds and I can not set the image on my desktop background. I have tried using System->Preferences->Look and Feel->Appearance->Background but it will not set. Okay so I installed xsetbg, it does not produce an error but it also fails to set the background. I switched from the compositing desktop to the non-compositing desktop, no difference.

When I get around to it; I will file a bug report!. :smiley:

Still unable to change wallpaper in the background.

Hi Bernard

When alpha comes out the end of this month and I hope to see this get automagically fixed. If not, I guess its time to file a bug report (unless someone else beats me to it).

I’ve been meaning to do that (file a bug report) but like you say, I will now wait for the Alpha and see if it is fixed, I’ll let you deal with the bug report @anon42388993 as I’m just that kind of guy!. :smiley:

1 Like

I just did several updates but it isn’t fixed yet!. :frowning:

If anybody wants to know, with compiz and ccsm then you will be able to activate the “wallpaper” effect in the “utility” category. You can then select some wallpapers you want to use. This is actually will works but you need compiz for that.

2 Likes

I've discovered the root cause of this issue and just uploaded a new mate-settings-daemon to the 17.04 archive which fixes the issue. It will take 4 to 6 hours to appear in your uodates :smiling_face:

3 Likes

Thanks @Wimpy,

the problem is now solved!. :smiley:

Merry Christmas everyone. :smiley:

Current DE look on my test partition:

2 Likes

I upgraded to 17.04 as well and just realized indeed, I can’t update the background… I tried the above suggested resolution, if I understood this well: sudo apt-get install mate-settings-daemon, but still facing the same problem - stuck with the (ugly?) default background. I guess I will keep googling - but this thread seemed the most promissing.
Many thanks
thomas

ok, this old post did it for me.


Specifically, run this command:
gsettings set org.gnome.settings-daemon.plugins.background active true
and the background i had selected immediately appeared.
nice.
Many thanks
thomas

1 Like

I was having this problem in Gnome on Ubuntu studio. I could not get the ‘change background’ app to launch when right clicking on the desktop. I ran this and everything started working again. Thanks!