Cannot create objects on desktop

Hello,
I have install Ubuntu mate on a VMware virtual computer.
I want to put some icons and launchers on the desktop.
I see them in the folder /home/jeanmi/Bureau but i do not see them on the screen !
Do you understand that ?
Regards,
JM

I think it could be related to language settings.

could you try this ? (in mate-terminal):

grep XDG_DESKTOP_DIR $HOME/.config/user-dirs.dirs

You should see:
XDG_DESKTOP_DIR="$HOME/Bureau"

Thank you for the answer.
Yes, exactly what i see :
[email protected]:~$ grep XDG_DESKTOP_DIR $HOME/.config/user-dirs.dirs
XDG_DESKTOP_DIR="$HOME/Bureau"
MateBureau

And The Folder... with launchers i can't see.
MateBureauFolder

Try opening the MATE Tweak tool (search in the menu for "Tweak" or whatever the equivalent word in French is). Under the first tab in the dialog that pops up, there should be an option to enable desktop icons, shown here as the first checkbox in the dialog:

Make sure that checkbox is checked. You can try tweaking with the other options while you're there, but I doubt that will help you much.

You might also try moving some of the desktop icons that you do see over to other places on the desktop; sometimes the desktop/file manager misplaces icons and lets some icons overlap others. It's a known flaw in the file manager.

Also, open the Bureau folder in the file manager as you show directly above, right-click on each file, and in the menu that pops up, click Properties. In the dialog that pops up, go to the Permissions tab, and make sure the checkbox near the bottom of the window called something like Allow execution is enabled. Sometimes, icons won't appear on the desktop until you make them executable, since these are launchers of executable programs.

Finally, if nothing else has yielded fruitful results so far (i.e., what I've said doesn't work), try copying another, non-executable file to your Bureau, e.g. a text file or picture file. If that appears on the desktop, then we can eliminate a lot of possibilities.


Good luck trying those things I listed. I hope one or more of them works.

1 Like

Ok !!
In french it was in Menu/Préférences/Mate Teak. But i could not modify nothing.
In a terminal *sudo chmod u+rxw *.desktop
Then reboot and it works fine.

Thanks for help !!
Jeanmi
MateBureaOk

1 Like