Cannot install MATE 18.04.4, Ubiquity crash v18.04.14.14

I've tried several times now to install Ubuntu-MATE version 1804.4 from a live USB.
Every time I hit "install," nothing happens. A circle spins for a few seconds, then stops.

I get an error message saying that ubiquity has crashed.

In the terminal I checked for ubiquity using dpkg -l ubuiquity, sudo apt update and sudo apt install ubiquity and saw that the live USB already has the latest version of ubuquity, which is

I'm now at a standstill with this. How can I get a functioning ubiquity and get the install wizard to open so I can complete the installation?

tell us about your hardware ...

Sure. I have a System76 Wild Dog, 64-bit desktop workstation, 4-core Q9650 3GHz, 8 GB ram. It has a BIOS, not UEFI.

Graphics: PNY Nvidia GeForce GTS 450, driver v. 367.44.

OSs: Ubuntu-MATE 16.04 & 14.04. Drives: 2 960-GB Sandisk SSDs.
I want to install Ubuntu-MATE 18.04.4 onto one of the SSDs (A standalone 960-GB SSD in an enclosure, that I later want to move into the Desktop box and boot directly from.)

The USB thumbdrive I'm using is a 4

Here is some of the lengthy error message report:




ubiquity crashed with PermissionError in___init___(): [Errno 13]
Permission denied '/cdrom/.disk/info'

is it possible to pass the parameter acpi=off during live boot ?

Perhaps the following askubuntu page would be worth reading? -

Good luck @watchpocket.

SOLVED: My live USB drive itself had permissions enabled for user only. I created read and execute permissions for group and other:

chmod go+rx /media/name-of-live-USB-stick