Cannot install Nvidia drivers due to unmet dependencies, broken packages


I've recently had problems disconnecting a secondary display (connected to a Lenovo docking station).

  • What should happen: I 'undock' my laptop (ThinkPad T440p) the laptop display is enabled automatically.
  • What actually happens: After undocking, the laptop display stays off, the fans start going, and I have to power down the machine to recover (all the usual shortcuts to switch displays, restart X, call xrandr --auto, do not work).

The current problem

Using the Nvidia drivers for the GPU (GeForce GT 730M) fixes the above problem. However, for some unknown reason, I can no longer enable the Nvidia proprietary drivers. When I choose the proprietary drivers in "Additional Drivers", the selection reverts back to the Nouveau option after a few seconds. This is surprising, because this was working correctly very recently.

Installing Nvidia drivers

I then checked whether the relevant packages were installed (nvidia-367). It wasn't. However, when I tried installing this package, I received the following messages:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 nvidia-367 : Depends: lib32gcc1 but it is not going to be installed

After a little digging, I found that lib32gcc1 isn't installed because of unmet dependencies:

The following packages have unmet dependencies.
 lib32gcc1 : Depends: gcc-6-base (= 6.2.0-5ubuntu12) but 6.2.0-7ubuntu11 is to be installed
E: Unable to correct problems, you have held broken packages.


  • I can't install nvidia-367 because Ubuntu needs gcc-6-base version 6.2.0-5ubuntu12, but the version in the repositories is 6.2.0-7ubuntu11.

If anyone has any suggestions, I'd be very grateful. I've tried switching to a different mirror. My current plan is to just wait, and hope that the required packages are updated shortly. I'd happily file a bug report, but I've no idea where the bug is (if one exists at all).

Thanks! :slight_smile:

System information
  • Ubuntu Mate 16.10
  • Linux thinkpad 4.8.0-38-generic #41-Ubuntu SMP Wed Feb 8 14:27:17 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Just to add further detail: the problem seems to be that I have an old version of gcc-6 installed:

~ apt-cache policy gcc-6            
  Installed: 6.2.0-7ubuntu11
  Candidate: 6.2.0-7ubuntu11
  Version table:
 *** 6.2.0-7ubuntu11 100
        100 /var/lib/dpkg/status
     6.2.0-5ubuntu12 500
        500 yakkety/main amd64 Packages

gcc-6-base 6.2.0-7ubuntu11

Thats the package Debian uses. Have you added Debian sources?

Ubuntu uses the requested version.

You can try forcing a package version.

Thanks for the reply.

I haven't, but I did install R via the instructions here, which provided a newer version of r-base than the 16.10 repositories. This may have installed the Debian version of gcc-6, but I can't be sure.

I've solved this problem by upgrading to the 17.04 development branch (admittedly, a slightly drastic solution). This installed the 17.04 versions of gcc-6 and gcc-6-base, which meant that I was able to install the nvidia-367 package.

Not ideal, but 17.04 seems pretty stable at this point.

1 Like