Cannot install Ubuntu Mate 16.04 on a Dell XPS 15 9560

I have a Dell XPS 15 9560 laptop I was able to install Ubuntu Mate when I first got the laptop, but after a couple of months the OS crashed. When I tried reinstalling Mate 16.04 it gets stuck on the ubuntu logo and would not go any further during installation. I did all the configurations in BIOS ie disabling the secure boot etc as required before installing Linux on this laptop. I tried Linux mint 18.2 and 18.3 and the installation was successful. I have also downloaded new Mate 16.04 image a number of times same result. At the moment I am using Linux Mint 18.3, I would love to go back to Ubuntu Mate. Please let me know if I am missing something or if there is anything else I need to do.

Hi @tpasi2020UG, I can offer some guesses. I’m assuming you’d like to install 16.04 LTS.

Are you able to boot into a live session ok or is that where the freeze occurs? You have 2 paths - “Try” and “Install”. The former also allows installation from the trial desktop. Exactly when do you get a freeze?

The ISO gets updated with new kernels in an attempt to keep the LTS updated for new hardware. For example, the original kernel was 4.4 while I believe the latest is 4.11. Perhaps an earlier kernel will be better (more specifically, an incompatibility of later kernels causes your freeze).

If you start here you’ll see images for original 16.04, 16.04.1, 16.04.2 and 16.04.3 and they are dated. Once on a kernel version it WILL stay there unless you explicitly change it.

There’s also a mini.iso for Ubuntu in general that installs via network (wired is much easier than wireless) and main packages for mate-desktop is there. This is not as easy an installer but happens to be my preferred method (you are up-to-date right away, too). I believe it only installs the original 4.4 kernel level unless you specifically select otherwise. The 16.04/64 version of mini.iso is HERE.


I have the same laptop and I can run 17.10 and 18.04 (daily build) successfully. I haven’t tried LTS, but I had the same problem as you when trying to install the first time.

I solved it by adding this to the /etc/default/grub file:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi=\"Windows 2009\" acpi_osi=Linux acpi_rev_override=5 acpi_backlight=vendor enable_fbc=1 enable_psr=1 disable_power_well=0"

The thing that makes it work is the acpi_* ones. The other ones seem to be helping with battery consumption (that and using the Intel driver for video when on battery, gives me around 7 to 10 hours of battery life).

The Arch wiki has good info:

Good luck!

I had some luck with adding nomodeset to the boot options.

  1. Boot from usb
  2. hit F6 ( in the installer menu)
  3. select " nomodeset"
  4. try and install

From here: “Note: Ubuntu Live freezes on the Dell XPS 15 in several versions. As pointed out by Milan P. Antonovic, you can solve this by adding nouveau.modeset=0 to the boot options.”

1 Like

f6 helped me to load ‘try ubuntu’ and managed to create partitions on my ssd.