Cannot keep/persist chosen default keyboard layout in Mate 1.24.0

I have seen Change keyboard and keep it - but that did not help.

I have (via mate-about) Mate 1.24.0 on:

$ cat /etc/issue
Ubuntu 20.04.2 LTS \n \l

Unfortunately, since:

Sorry, new users can only put one embedded media item in a post.
Sorry, new users can only put 2 links in a post.

... all of my work putting screenshots has now been wasted (why not put out an alert the very moment I paste one link more than my quota is, ffs?), so here is the link to the post with all images on imgur (not sure why it gets shown as an image - just click on it, all of the images should be in this post):

Here is what I've tried:

  1. First, I reset dconf using

    dconf reset -f /

    Note, as shown on the screenshot, that after this, the OS recognizes English as "language for menus and windows", but Danish as default keyboard layout (most likely, because I had to specify Danish keyboard during installation from USB stick, because that is the kind of keyboard I had):

    i.imgur .com/klOrLy6m.png

  2. Then, I add the US english keyboard layout:

    i.imgur .com/EZzTjGsm.png

  3. Double-check: Keyboard Preferences now shows the added US English keyboard layout as second. Then, I select the Danish keyboard layout and remove it:

    i.imgur .com/1H4ieTlm.png

  4. Log out from the system:

    i.imgur .com/JukoOmlm.png

  5. Log back in again - since US English should be the only keyboard layout right now, it is the default, as expected. Then I again add the Danish keyboard layout as second one - hoping that the US English keyboard layout, as first, will be the default one:

    i.imgur .com/Q3F7oG1m.png

  6. Log out again:

    i.imgur .com/YsoXyQbm.png

  7. Now, let's focus on the login screen at this time - on this screen, at this time, the default keyboard layout is Danish!:

    i.imgur .com/yQ3uXjLm.png

  8. Now that I log in back again, the default keyboard layout is unfortunately still Danish, even if I wanted the US English one to be the default:

    i.imgur .com/Y7pyIwSm.png

  9. Finally, I decide to test the "Use default option" in gconf-editor - once I do that, the additional (actually, all) keyboard layouts from "Custom value" are deleted - so after that, I could not even change to US English keyboard layout manually!:

    i.imgur .com/y0VUfyam.png

So: how can I set up Mate, so that US English is my default keyboard layout -- and that persist across logout/logins and reboots, -- even if I have Danish as a second keyboard layout?

Hey :slight_smile:

Please try this way :

sudo dpkg-reconfigure keyboard-configuration

1 Like

Many thanks, @olek:

That was it - just a note: basically, this command allows you to re-choose the default keyboard, and I did so choosing English/US generic keyboard; after reboot, login screen shows US as default keyboard, and "en" as starting keyboard layout once you log in to the desktop (and "dk" is still there as a second layout option) - so that is great, all works now!

Thanks again!

1 Like