Canon MG2900, Getting it to print

Hi. I have a file (cnijfilter2-5.00-1-deb) that is a driver for my Canon MG2922--it's a wireless printer. When I try to run the file with Gdeb package installer, I get a message that the file may be corrupt, or the permissions might need to be changed. I can select the printer for scanning, though. I have tried "chmod +rwx cnijfilter2-5.00-1-deb", as you can see from the screenshot. I'm unsure what else to try.

Anthony, the file is not a .deb file (see the -deb).
It is a directory that contains an

1 Like

Thanks for spotting that the file is not a .deb. I am wondering if someone could provide a link to the file: cnijfilter2_5.00-1_amd64.deb I tried clicking install for the .sh and ran in terminal, but the printer is never found. I am hoping the .deb file would install the driver for the printer. I have no printer usb, so am only hoping the network finds the printer.

Hi. I don't need any extra help now--I just went ahead and bought a printer usb. The printer worked straightaway. Thanks everyone.