Canon Pixma TS9100 will not scan


#1

I installed the drivers for a Canon Pixma TS9100.

It prints fine, but xsane can not see the scanner. Same with simple scan.

[email protected]_~/Downloads$ sudo sane-find-scanner
[sudo] password for andy:

sane-find-scanner will now attempt to detect your scanner. If the
result is different from what you expected, first make sure your
scanner is powered up and properly connected to your computer.

No SCSI scanners found. If you expected something different, make sure that
you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1820 [TS9100 series]) at libusb:002:003
Your USB scanner was (probably) detected. It may or may not be supported by
SANE. Try scanimage -L and read the backend's manpage.

Not checking for parallel port scanners.

Most Scanners connected to the parallel port or other proprietary ports
can't be detected by this program.

Sane found the right printer?


#2

I found out that scangearmp2 will do scanning.

I found another problem.

If I shutdown my computer and restart, my printer says it was not shutdown properly.

Is there a way to stop that?


#3

Sometimes checking out existing bug reports can provide a work around or solution. See - https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012 and in particular comments 19, 25 and 28 for a possible clue to solve your problem. Good luck Andy.


#4

Is your post about my problems with no scanning?

Because I got that fixed.

My current issue is with the power button.


#5

Advice on operating complex machinery is not my particular talent. It would be nice if you had told us that your scanner is now functional. Glad to hear about that Andy.

Edit: I saw that you got scangear working, I just assumed that you wanted Xsane and Simple Scan to work. My bad.


#6

No problem and thanks for your help.

With the new printer, I no longer have to unplug/plug in the printer usb cable all the time to do scans. :slight_smile:

I would like to use the advanced mode of scan gear, but it appears that is not possible.

But it does scan to a very high resolution and images are easily to change the resolution with Gimp.

I made a post on the canon site. If anyway knows how to fix my problem, they should. :slight_smile: