Canon TS9120 is not seen by Document Scanner

I have UM 20.04 installed on my hard drive.

I installed the drivers for a Canon TS 9120 printer/scanner.

However, Document Scanner says it can find scanner?

scangearmp2 can not find scanner either.

Could someone help me?


Have you install the canon backend program found in the Synaptic Package Manager. Once I installed the program my canon scanner was found., just a thought.

I installed it. Did not help.

I tried using the Wifi mode of my printer.

No luck.

For the time being, I will keep 18.04 and only use it when I need to scan.


Hi fixit7,

try the following. :grinning:

1 Like

I do use scangearmp2 in UM 18.04.

But it does not work in UM 20.04.

Something got broke during the development of 20.04 in terms of Canon printers.

Should I report it as a bug at Launchpad?

To use my scanner, I had to leave 18.04 installed.

Which uses a lot of space.

Can I delete large portions of 18.04 except what is necessary to run my scanner?

I decided to wait about 2 weeks to see if I can get it working in 20.04.

If, not I'll just remove 20.04 and stay with 18.04.

Maybe it will get fixed in the future.

Hi fixit7,

that link I posted is indeed 4 years old and that may be why it isn't working for you with 20.04?. :thinking:

I made a post at the Canon website.

There is not only source code, but an RPM file and a .DEB package for that scanner on Canon's website. Not going to work if you don't install the driver. You say you posted on Canons forum? And no one from Canon said "Hey did you load our driver?"??

I installed the required Canon driver.

It works for 18.04. It should work for 20.04.

Try the following link. :smiley:'t%20auto-detected

wolfman, your link led to a non-existent page for me. I suggest the two following links -

and perhaps this one too -

1 Like

My scanner is not in dll.conf.

But lsusb finds it?

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04f9:0045 Brother Industries, Ltd HL-2240 series
Bus 002 Device 004: ID 04a9:1820 Canon, Inc. TS9100 series

sudo sane-find-scanner

found USB scanner (vendor=0x04a9 [Canon], product=0x1820 [TS9100 series]) at libusb:002:004

So it now finds your scanner. If it's found, have you actually tried the next step which would probably be SCANNING SOMETHING?

You might want to read my first post.

I had issues with a Canon scanner on UM 20.04 and followed the hint at
"remove the “ippusbxd” package".
That worked.

1 Like

Thanks so much. It worked. :slight_smile:

1 Like

Nice to read that :blush: You're welcome!