Can't autostart Dropbox at startup

Hi,

I'm trying to get Dropbox to autostart on login. I have the flatpak installed.

I try to make a new entry with the command
flatpak run com.dropbox.Client
however, when I restart, that autostart entry disappears.

I would recommend to install Dropbox as deb-package.
It has good feature - it integrates to Caja file manager.
So you need to install one package:

sudo apt-get install caja-dropbox

To make it work we need to fix permission bugs by running

sudo chmod a+rx /var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64*/libdropbox_apex.so
sudo chmod a+rx /var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64*/libdropbox_sqlite_ext.so

restart Caja and then enjoy :slight_smile:

1 Like

I've installed the native repo's dropbox, but it's still not starting on boot. My autostart settings just reset themselves on every reboot.

Then it may be permissions issue. You can reown the corresponding folder with:

sudo chown -R $USER:$USER ~/.config

and then ask Dropbox to autostart again:

caja-dropbox autostart n
caja-dropbox autostart y

then reboot and login back.

Sorry to be a pain, but those commands don't appear to work. I get no error messages.

My start-up apps still get reset on reboot.

Ah ha. I worked it out. It was a simple permissions issue. I just needed to set the permissions of the autostart config folder and I was good to go.

1 Like