Can't boot into system :error message - A job running for hold

I am seeing the "A job running for hold until boot process finishes up (xx Min XXs/ no limit)" error after i updated my OS.
I have seen several solutions for this kind of issue in askubuntu forum. but, all the solutions aren't useful for me as i can't access the terminal. by hitting "alt+ctrl+F1/F2" doesn't give me access to terminal, it shows me blank screen where can't type any commands.
please help


after 23 minutes.

Hi, @Pratyay .

I've searched the web for the error message that appears several times in those screenshots, namely the following error message:

[FAILED] Failed to start Light Display Manager

The best result I've found was the following Question & Answer in the "Unix & Linux Stack Exchange", asked and answered by the user ex1led in May 2020, where the user was also getting that "[FAILED] Failed to start Light Display Manager" error message and the "A start job is running for Hold until boot process finishes up ( <mins> / no limit)" message:

The answer in that web page also seems to fit your situation (it implies entering the so-called "Recovery Mode" in the "Advanced Options for Ubuntu" section in "GNU GRUB" menu. If you don't know how to enter "Recovery Mode", you may find instructions to do that in several web pages such as "How do I boot to recovery mode in Ubuntu 20.04? - Ask Ubuntu"):

" So what the main problem was that the display manager was not working correctly. The most common solutions/suggestions that you can find on this topic (e.g., [1],[2]) do recommend (among others) that you dpkg reconfigure the lightdm package. But in order to do so, you need some terminal prompt.

As mentioned above I was not able to access any kind of terminal by using ctrl + alt + f1/f2. What I did actually, was to access ubuntu in recovery mode and from there get a root terminal in order to proceed with the reconfiguration of the lightdm package.

After I logged in as a #root I did sudo dpkg-reconfigure lightdm and then rebooted my machine. The error persisted and so I tried to remove completely and then re-install the display manager. I followed the same steps, selected Ubuntu Recovery mode from the OS select menu, and then I selected enable networking before I open a root terminal in order to have a network connection and be able to fetch the package.

Seems that I've opened Pandora's box at this point. There is a bug ( see [3],[4] ) in the recovery mode, and although I am using UbuntuMATE 20.04 and the error concerns an older version of the kernel apparently it still exists (?). So...I had first to enable the Networking of my system manually.

I removed (sudo rm) the dangling link of /etc/resolv.conf -> /run/resolvconf/resolv.conf and then I created another resolv.conf file at /etc/ dir with valid DNS servers. I saved the file and restarted the network manager. After that I tried ping 8.8.8.8 and I got a response.

# resolv.conf file 
nameserver 8.8.8.8 # primary   DNS server for Google DNS
nameserver 8.8.4.4 # secondary DNS server for Google DNS

Since I now had access to the internet I did the following:

  1. sudo apt purge xorg lightdm
  2. sudo apt autoremove
  3. sudo apt install xorg lightdm

After rebooting the machine I was able to log-in successfully. "

I hope that helps :slight_smile:

3 Likes

Thank you Ricardo, for your support.
My issue got resolved. However, i had to take a diffrent aproach to resolve it.
I could not access Ubuntu Recovery Mode by pressing shift or esc, hence I had to disable fast boot & then set the boot mode to Legacy Mode instead of UEFI. Only after that I could access the recovery mode.

Then, as prescribed in the article shared by you, I purged lightdm then reinstalled it. But the issue didn't get resolved. Then thought myself lightdm & gdm does the same job. I installed gdm3 & replaced lightdm with it. But, MATE desktop & Panels keeps on crashing form time to time, now I am using Gnome DE. It works fine but, I prefer MATE more.

PS.- I tried to switch to lightdm, same issue re-occured, A fresh OS install will fix it, I think.

1 Like