Can't Get Installation on MBP 2.2 to boot (ie, 32-bit EFI Macs)

So, I was able to create a bootable USB installer using this -> Option 4.

During live CD session, I create a new MSDOS partition table on the target drive, with the following partitions:

ubuntu-mate@ubuntu-mate:~$ sudo parted -l
Model: ATA Seagate SSD (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  630MB   629MB   primary  fat32           boot, esp
 2      630MB   1704MB  1074MB  primary  linux-swap(v1)
 3      1704MB  500GB   498GB   primary  ext4

ubuntu-mate@ubuntu-mate:~$ sudo fdisk -l
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Seagate SSD     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x18fbe4e3

Device     Boot   Start       End   Sectors   Size Id Type
/dev/sda1  *       2048   1230562   1228515 599.9M ef EFI (FAT-12/16/32)
/dev/sda2       1230848   3327999   2097152     1G 82 Linux swap / Solaris
/dev/sda3       3328000 976773119 973445120 464.2G 83 Linux

Installation seems to go great, but I get the "FOLDER?" message upon startup. I tried to OPTION + COMMAND during boot, thinking I have to manually select the EFI boot device, but that didn't do anything either.

Here are some (animated) screenshots from the installation when customizing the installation partitions.


Lastly, before clicking "Install Now", I tried selecting both /dev/sda and /dev/sda1 (efi) as the device for the boot loader installation. Neither worked. Should I have selected /dev/sda3 (ext4)?