Can't install 20.10 using screen reader

I am trying to install the AMD64 version of 20.10.

As a blind user, I have been pleased with the care the developers have taken to ensure screen reader accessibility in Ubuntu Mate. I should have sent a thank you note a year ago.

I cannot figure out how to install 20.10 with Orca. After I have booted the USB stick, I press the alt-windows-s combination and Orca starts as expected; but I cannot navigate the installation window. Orca reports the window name as "Installer frame" or something similar, but I hear nothing when using the tab and arrow keys to try and find the usual installation options and buttons.

I hope I am doing something wrong. If the developers have decided accessibility is no longer a priority... well I'll be disappointed. For all I know, I am the only blind Ubuntu Mate user.

When I couldn't make it work, I installed 20.04 with no problems. From there, I am tempted to do a distribution upgrade to 20.10, but worry that there may be other screen reader issues.

Would someone kindly try to confirm this behavior before I submit a bug?



1 Like

I'm not qualified to reply with any specifics, but I'll provide the only details I'm aware of.

There was a bug in all release-candidate or final ISOs of Ubuntu 20.10 (& flavors such as Ubuntu-MATE 20.10) until only hours before the actual release.

This meant sound was muted unless the user jumped a few hurdles to get it to function. This was recognized as a big problem for some Ubuntu MATE users, and the problem fixed and re-spin made in the final hours before release.

I would therefore ensure you've got the released Ubuntu MATE 20.10 ISO, and not an earlier one (even a few hours earlier as mirrors can often sync early, those will have muted sound).

I'm offering this as only as an FYI and possible cause, until someone more knowledgeable, or a Ubuntu-MATE team member can offer more helpful advice.

A correct dated ISO will have 2020-10-22 as it's date.

I would check your SHA256SUM matches the detail found in

9c7eee81c26ee28d825635641a4d948a940b0c04b7b506d422ac674b204807e5 *groovy-desktop-amd64.iso

(found at

Thanks for your post. I doubt this is the same issue as I can hear the screen reader start with the usual "screen reader on" announcement. It also speaks "installer frame window" when I press alt-tab.

I will check the date of the ISO I used and download again if it is the earlier one.




@EternalNovice, firstly, welcome to the Ubuntu MATE community. I'm glad I found somebody who has experience with screen-reader installation. I had tried this method several times during testing period, but could not get it to work.

'No' to both the points. Like you, I doubted if I'm doing something wrong. But since you could install with 20.04 but not with 20.10, definitely we are not doing anythong wrong in our procedure. Also, accessibility is definitely a high priority item for developers. Like @guiverc mentioned, there was a bug wrt default volume being muted, that would have affected screen-reader install. It was taken very seriously and the whole team worked really hard and able to get a fix overnight. The current situation is another bug that needs to be escalated. There is a bug report. I had put my comment there but as you had success installing 20.04 (and possibly previous releases), I'm not sure if that bug is relevant. You may either add your input there or create new bug.


I see exact same issue as Jason.

  • The default sound issue is fixed.
  • We are able to start screen-reader and even the installer.
  • However thereafter there are no screen-reading for installer window.
  • If I move around, choose any other items, the screen-reader reads. Just that it cannot see options inside installer window. For 'Welcome' app, it reads-out the buttons/icons.
1 Like

I would recommend a new bug report. The only release impacted in that bug is saucy which means it should be flagged as EOL so I would suggest starting a new bug.

FYI: I'm not a MATE team member, just an occasional user involved with testing & another flavor

Noted. Is there no such issue in Lubuntu?

@EternalNovice, it is better if you raise a new bug. You have experience installing and can articulate better. I can add my comments as needed.

1 Like

Lubuntu has no such capabilities. :frowning:

(and I doubt we have the resources to add it :grimacing: though I think there are issues with our use of calamares)

Thanks @saivinob

1 Like

I found the exact symptoms describe in bug #1874283 for 20.04 which likely has carried over to 20.10. In the comments, they mention that the problem doesn't exist if booted from EFI mode.

I have no idea which boot mode I am in; I just use the keystrokes for booting from USB on this PC.

Should I comment on that bug, or open a new one for 20.10? I've never done this and don't know the proper etiquette for this situation.

1 Like

Sorry you are experiencing this.

There is no need to open a new bug for this issue. You can just add your comments on the existing one.
Please also mark that this issue is affecting you.

Just did a bit of testing and this is what I am seeing:

Alt+Super+S starts screen reader
Alt+Tab changes to super-user installer

Orca is working in other applications during the session (ex Firefox) however the screen-reader is not processing anything with the Ubuquity installer window.

1 Like

I have posted a comment on #1874283 and marked it as affecting me. Someone has changed the status to “confirmed”.

Thanks for all your help,


This bug unfortunately is continuing in 21.04 daily builds as of today.

1 Like

Hi all, so i am verry new to linux. I am first trying it out with a virtual machine, using virtual box as the virtualization software. I pressed super+alt+s to turn on the screen reader, and it turns on. but when i navigate in the installer window, it does not speak at all. is there a work around for this, or should i download another ubuntu version to try out? I am using ubuntu mate 20.04.
I also read some where I should enter the terminal and type "orca --replace" but that just restarts the screen reader, but the issue still remains the same.

I'm a completely blind user and unfortunately, this is still happening on ubuntu mate 21.04. Is there any plans/ways to fix this? I would love to try this distro :slightly_smiling_face:

Hello @thetechguy, welcome to the forum. :ubuntu_mate:

I am quite sorry to hear that the accessibility support in the installer isn't working out. We are well aware that an issue exists, and we're getting closer to the culprit (I think), but we still haven't found the problem (much less rectified it).

@saivinob has done us a great service by consolidating the evidence regarding this case :mag: into one place on the forum:

Hopefully we can get to the bottom of this and fix the bug :bug: soon, preferably before version 20.10 comes out in October.


Happy to hear that the team is working on this! Thanks for sending me the relevant link to the bug report/topic :smiley: I'll check it out.

I can definitely confirm. I am totally blind, and cannot install Ubuntu mate using a screen reader. Furthermore, if I drop to a terminal, and try to run anything like gparted, I get the same behavior. I was having this issue with 20.10, and have just wrote the iso for 21.04 to my flash drive. From what I see here though, the issue is not resolved. Is anyone else having trouble running tools like gparted Using a live flash drive or DVD? Any work around or help would be greatly appreciated.

Welcome, @guyster1045!

The good news is, I found the bug that prevents Ubiquity from communicating with the screen reader. I even produced a fix for the issue too. So on that level, the problem should have been solved by now.

The bad news is, the Ubuntu development team is a big bureaucracy, and they seem to be either overloaded or dragging their feet. We are all waiting for them to review my fix, and we are praying that my fix will be applied before Ubuntu MATE 21.10 is released around October fourteenth. I keep nagging a higher-level member of the Ubuntu MATE Team to hunt down and nag the Ubuntu team, so hopefully the Ubuntu team will eventually get our drift and apply the fix!

I'm sorry that you're suffering from this -- I just responded by nagging yet again. I sympathize with you and all of our other visually-impaired users.

Sorry, but that's the best I can do for you now.

(By the way, a note to our non-visually-impaired users: If this post looks weird, it's because I wrote it in hopes a screen reader would have an easier time processing it.)

(EDIT: I previously wrote October twenty-second as the final release of 21.10, but it turns out it will probably be released a bit earlier than usual, according to Impish Indri Release Schedule - Release - Ubuntu Community Hub. Thank you, @guiverc, for letting me know!)

1 Like

Is the bug you found preventing utilities uch as gparted from communicating also? Not only am I unable to install, but I cannot drop to mate terminal and run gparted. Thank you much for your development work, and I hope to see this fix committed very soon. Installing the operating system, and partitioning your hard drive are very important and necessary tasks.


Visually-impaired users of the "interim" releases like 21.04: You're in good hands. Finally, after months of work (and waiting), the latest 21.10 daily build live ISO images have been fixed so that Ubiquity can communicate with the screen reader. :partying_face: The final release of 21.10 should be only a few hours away (if I understand correctly), so if you've been waiting to install until this bug is fixed, you can do so in just a few hours' time!

For 20.04 LTS users affected by this bug: Unfortunately, the bugfix has not yet been backported to 20.04; it's unclear what the cause is on that version, and it's even disputed whether there's even an issue -- some of us have been unable to reproduce the bug there. :man_shrugging: 22.04 (due out in six months) should have the fix applied, though, and in due time we might have a fix for 20.04, so don't let your hopes down yet!