Can't login after trying to install Prey

Hi everyone,
yesterday I tried to install Prey antitheft but I got an error during the installation… a window popped up with the error message but I just cancelled it and moved on. The thing is that, later, my laptop got on sleep mode and when I turned it on again, my password didn’t seem to work anymore. I rebooted the system and it asked me to login with my password (which never happened before).
I did somre research on the net, and tried a couple of thing but they didn’t work (BTW, I can access via Terminal without problems, it’s just the graphic mode):

  • uninstalled prey through the terminal

  • sudo chown usuario1 -R /home/usuario1/
    sudo chgrp usuario1 -R /home/usuario1/

-$ sudo chmod -R 775 /home/pepito
$ sudo chown -R pepito:pepito /home/pepito -

Any ideas?? thank you

I also tried this tutorial 3 Ways to fix Ubuntu gets stuck in login screen loop, none of the first two options worked and when I tried the last one, it seems I may have accidentally deleted Xauthority because the command doesn’t work and get a message saying I need to be root to reconfig…