Can't Mount Drives or Change Settings over VNC

I’ve got UM 16.04 installed on my RPI 3B. Almost everything is working great, but I’m having trouble doing some things on the desktop when logged in to my admin account over VNC. In particular, I cannot change most settings, run Synaptic or mount drives from the GUI. Some applications will not even open. With some apps (such as Synaptic) opening them from Terminal using gksudo helps; for others it does not. Even when some settings apps (such as Users & Groups or Networks) open, I cannot change many settings or click on any of the advanced settings buttons. In Networks, pressing the Unlock button does not even open the password dialog.

I am using TightVNC over an SSH tunnel. TightVNC is running under the same user account I am logged in under. If it matters, I’ve set that user account to automatically login to at startup.

Have you tried using Vino instead of TightVNC for comparison?

Can’t get vino or x11vnc to work, which is why I’m using TightVNC.

Try installing “gksu” and use that in front of the command that requires root access, for example

gksu synaptic

You need to set a password for the user “root” before that will work. So do a

“sudo passwd”

When being asked by gksu, use this password.

I don’t know if there is a better way, but at least that worked for me.